Confused about unknown node

Tags: #<Tag:0x00007f7398411cf8>

Under the Z-Wave Network Management node list, one of the items is "Uknown Node 8 (Node:7 Probe). It keeps showing up even after a reboot. I triad manually setting is_failed: true via the Developer Tools and then selecting “Remove Failed Node” under the network management page. However, the node remains and it is listed as “Initializing (Probe)”. I’m confused about what to do to get this removed from the list. Could it be that this is an old Z-wave device that I no longer have?

I have the same problem and it is annoying as hell…removed it from zwcfg, did what you did as well, at first reboot it disappears, at second reboot it pops up again, like a resurrected vampire.

Is there really no solution for this? Saw another topic on the subject as well and the is_failed: true advice was the only option offered.

Yes, that is_failed approach doesn’t work. I think it’s because the node is stuck in initializing state. Any chance that you paired an old device with your Z-wave stick and that device no longer exists? I’m wondering if that node is “left around” from a previous device I used to have.

For sure that’s the case, all existing ZWave devices are accounted for and some have thankfully been banished from my home, it must be one of those.

FYI, I finally got around to removing all nodes, factory resetting the Z-wave stick and then re-adding the nodes. The unknown node was gone at that point.

Yeah, no :stuck_out_tongue:

I’d rather wait for the new ZWave addon for HA and migrate to it or just toss all my ZWave stuff in a metal container, pour gasoline and light them up :smiley:

If you download Z-wave PC Controller 5, you can remove the faulty node from your controller without having to completely reset the controller.
You can find it here but you need to register first.
https://www.silabs.com/products/development-tools/software/z-wave/embedded-sdk
User guide:

After that, launch the program, mark the node as failed in the program and remove it. That will actually work, I did the same way too.

3 Likes

I managed to remove the Unknown node by setting both is_ready and is_failed flags to true within states. After a restart the node was gone. Did a second restart just to make sure it stayed gone…

2 Likes

@BenS just letting you know, I tried your suggestion and I could not get rid of that bloody device… ive tried just about everything… node-8 will just not go away… thanks for your suggestion tho.

My god, I spent hours on trying to remove this one bloody node… and until I did what you suggested with the siglabs software, I was stuck… I even had to install a windows 10 VM so I could install the siglabs software… anyway went through that software and set the node I was trying to remove to ‘failed’ and then ‘remove failed’ and that got rid of it. Also when you go back to home assistant, you have to mark the node there as failed and remove it from there too but this time it stays gone :slight_smile:
Thank you very much @Discoverer really appreciate it.

Thanks! I just marked @Discoverer’s reply as the solution. I ended up just doing a factory reset and re-adding all of my nodes since I didn’t have that many. But, @Discoverer’s approach is better if you don’t want to do a factory reset.