Connect a new XBee3 device to ZHA

I have HA running the latest versions and installed ZHA (using a SkyConnect dongle). I also have some XBee3 deivces direct from Digi that I’ve put into a couple of devices about a year ago (before I got into HA). I have updated the XBee3 to the latest firmware (product XB3-24, ‘Digi XBee3 Zigbee 3.0’, verison 1012).
Looking at the ZHA ‘network Settings’ I see:

I’ve tried using the latest XCTU version (on my iMac M1 - latest OS) to connect a XBee3 module sitting in a ‘SMT Grove Development Board’ to ZHA. I’ve used the ‘extended PAN ID’ and set the ‘Scan Channel’ to only select channel 20. The XBEE3 module is currenty wset as an end device.
However I must be missing something else as I can’t get the XBee3 to be recognised.
One other thing that puzzles me is that, when searching for a new device, the ZHA says to put the device into ‘pairing mode’. How do I do that for the XBee3 module?

Reset the Xbee to default settings. Apply the settings from this post (leaving all others to default).

The Xbee goes into pairing mode immediately if it’s not already joined to a network.

Thanks for the quick reply. I’ve tried those settings but no luck. (BTQ I can connect to the XBee3 coordinator that is about 0.5 metres from the new SkyConnect dongle so I don’t think there is an issue with the signal strength etc.)
Two differences I noted:

  • I don’t have a ‘ZA’ parameter
  • I don’t have a ‘A0’ parameter but i do have an ‘AO’ parameter
    I reset the XBee3, set up those suggested parameters and, when I couldn’t connect, I dumped the profile to see what it says:
<?xml version="1.0" encoding="UTF-8"?>

    <description xml:space="preserve"></description>
      <setting command="NJ">5A</setting>
      <setting command="NO">3</setting>
      <setting command="EE">1</setting>
      <setting command="KY">5A6967426565416C6C69616E63653039</setting>
      <setting command="NK"></setting>
      <setting command="SP">64</setting>
      <setting command="SN">AF0</setting>
      <setting command="AO">3</setting>
      <setting command="BD">6</setting>


Got it working.
I think the ‘ZA’ parameter is a typo - ‘ZS’ seems to work.
Ditto the ‘A0’ parameter should be ‘AO’

1 Like