Connecting ancient DVR to HA


So I have recently set up HA and connected several IP Cameras. In this building, there are a lot of old CCTV cameras that weren’t used for ~10 years, and I’d like to connect them to HA to still get some use from them since they are already there.

I found an old DVR from around 2004, I guess (The recommended OS is Windows XP/2000, and the CPU is a Pentium 4). Surprisingly it supports ethernet. I connected to it and got to where the camera feed would be, but instead, I saw:

“Please click here to download the installation program which does not support IE browser.
After finish downloading, disable the browser and implement the program by manual.”

When I loaded it in Edge in Internet Explorer compatibility mode and downloaded the program, I actually got a video feed! Of course, this wouldn’t work in HA, but this thing also supports RTSP!

When I tried it in Home Assistant, it gave me an error message “Timeout while loading URL”. I tried it in ContaCAM, and it seemed to connect, but this gave me the error “Error 5XX”. I really don’t know what is happening. Maybe HA doesn’t support some old RTSP protocol?


Can you see the rtsp feed in vlc?
What url are you using for rtsp?

Yes, I do!
I am using the URL that the DVR specified:

I put this same exact address in HA, and it did recognize something. However, it’s just a still image.
The weird thing is that I didn’t need any password or user name or need to specify the RTSP protocol. I also got the error “Error starting stream, see logs for details (0)”.

EDIT: I got it working with ContaCAM, but now I also noticed that the resolution is 176x144 when the camera supports 720x288.

Where in ha did you put the address ?

I put it in the Stream Source URL box. This is the config I used:

Ok, that was what I was asking thanks. Generic Camera.

In vlc, what does it show you the codec in the video is?

I’m sorry, but I can’t seem to find any information about the codec in VLC. ContaCAM shows more info, though:

Hi. Other than the resolution, everything is working fine!
I connected this weird camera through the motionEYE add-on and added the motionEYE integration, which allowed me to get a camera feed in Home Assistant!

If you know why please let me know what is wrong with the resolution :wink:

Thanks for the help!

Try with rtsp adress ending in CH0 for the first stream. My NVR has ch nr 0 for stream 1, and 01 for substream 1 - with lower resolution. Maybe this is the case with your equipment.

And one more thing, try rtsp:// - you never know :wink:

There is software somewhere to search for rtsp streams. I can’t recall details. Start with nmap to check what ports are open.

1 Like

Try onvif discovery tool.

This does work but the resolution is way worse than it should be with rtsp://

I didn’t try rtsp://10.0.070/CH0 so I’ll do that.

UPDATE: This didn’t work.

I unfortunately cannot access the NVR right now, but as soon as I’ll be able to I’ll let you know what the tool found.

It doesn’t pick up anything :frowning: