Connecting to hidden SSID network

I have just discovered that if I have set the hidden: true parameter for the network, ESPHome will not connect if it isn’t hidden (I was replacing the AP and changing the network configuration).

Is this by design to meet a specification somewhere or is it a bug?

Once the AP was set to hidden, the devices connected even without the fast_connect parameter being set :slight_smile:

Not tried the hidden parameter. I connect to a hidden SSID with just “fast_connect: true” did you try that?

No, I didn’t. Interesting that it connected to a hidden SSID without the hidden parameter!

Hi …
How can I set the „fast-connect“ in a HA yaml code ?
Thanks for you’re help.


  ssid: !secret wifi_ssid
  password: !secret wifi_password
  fast_connect: true # Optional. Required if connecting to a hidden SSID

You know how to go to the website and use a search box right? You could type “fast connect” in rhe search box and that will take you to where it explains it and how to set it.

Thanks for you’re help, appreciate.