Connecting to internal URL

I was connected to HA using an external URL via duckdns and came home. My home network was not listed in the internal URL list so I added it hoping it would change the connection to internal automatically but it didn’t. So I did the following:

  1. Refreshed - wouldn’t change the connection to internal
  2. Logged out, then back in - wouldn’t change the connection to internal
  3. Closed the app and restarted it. HA API connection (or manager) unavailable with blank screen. Settings showed my name and zones. External URL was empty. Tried to enter my duckdns info and kept getting an error related to parsing the url. Tried several times with the same result. v1.5.1 app could access ha.
  4. Deleted the v2.0 app, reinstalled and logged in with the external url ok.

Still not connecting with the internal URL.


  1. How so I switch to my local network if I enter it when coming home or adding it.
  2. After logging out the first time, not sure why I would get an API error trying to reconnect that prevented the login screen from being displayed but would display my name and zones.
  3. After reinstalling and going through the setup process, the keyboard would not display until I went to another app then came back to the ios app.

I’m running on an iPad Air 2019 (1 week old), ios 12.3.1, ha 0.93.1, app v2.0b60. I’m using the SwiftKey third party keyboard.

1 Like

Is your WiFi SSID listed in the settings? Mine switches to internal URL when it is on a listed WiFi network.

1 Like

It is. I have multiple device trackers that are obsolete for my iPhone and iPad plan on nuking everything in settings,.storage, etc to clean everything up. Maybe it will connect then.

If you’re using DuckDNS add-on then you have a certificate. The certificate is only good for your domain name. Could the ios app be choking on the certificate failure?

1 Like

Could be actually. I use Caddy as a reverse proxy so I can use either the http://local_ip:8123 or… that could be the difference.

Still having issues after spending the day cleaning up my system and trying to get it going…

I have nuked all previous instances of the mobile_app, integrations (several times), entities, ios app on my iphone and ipad several times and have added it back to only my iphone. I’ve cleaned up the .storage mobile_app file, known_devices.yaml, core.restore_state and core.entity_registry.

  1. When adding the ios app on the iphone, it scans the network (home network-CobbNet-5G) and only finds my connection. I connect through duckdns to HA, enter my username/pw and continue on through the installation & setup with only one issue as far as I can tell.

–There is no entity for the iphone (there used to be one with the big-big-uid). I don’t know if there should be one and it is not showing or if robbie and others have now hidden it. known_devices.yaml only shows the gary_iphone entry I’ve been using for a long time.
–sensor.ssid=CobbNet-5G (my internal network)
–sensor.lastupdate=Initial or Background Fetch

  1. My DuckDNS certificate expires July 6 so it is not out of date
  2. My RPi has a fixed ip address, I have trusted_networks set up but I can not log into the ios app using the trusted network, only the DuckDNS connection.

My config.yaml has:

    - type: homeassistant
    - type: trusted_networks
        - ::ffff:
      #allow_bypass_login: true
    - type: legacy_api_password
      api_password: !secret ha_password

  #api_password: !secret ha_password
  base_url: !secret duckdns_username
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem
  1. I am getting a notification that “Login attempt or request with invalid authentication from”
  2. I have no issues SSHing in using WinSCP or PuTTy. They are using the SSL certificates and keys.

My Config:, HA 0.93.2, IOS App v2.0b60, RPi 3B+, Win10,
ios v1.5.1, iPhone XS with ios 12.3.1

My biggest issues, I guess is:

  1. geocoded_location never updates.
  2. trusted_netowrks not being recognized
  3. some type of authentication error/certificate error.

I also have the LogViewer addon but am having lots of issues displaying the log file where it worked fine a few weeks ago.

Any thoughts are appreciated.

But your certificate is only good for your DuckDNS address. It doesn’t work for local IP addresses.

But you said yourself it only sees the DuckDNS PUBLIC connection and not the local IP. The system thinks it’s coming from outside…not internally.

SSH and SCP don’t use SSL certificates.

Do you know if it is possible to add more than one WIFI SSID? I have tried adding two wifis to the app using “,” and “;” between them but it doesn’t work. I have just been able to make it work when I just include one SSID

Under SSIDS there is a menu item to add new SSID so you can have more than one listed there.

Are you talking about the Home Assistant android app? When I click in “App Configuration” after “Home Assistant URL” I just see “Home Network WiFi SSID” and when I click on it I can just write one SSID

Give this thread is about the iOS app then no, I’m not talking about the android app.

Ok, then that must be the reason. If this functionality is already in the iOS app, hopefully they will add it to the android app soon

I manage to make it work, the i put the local ip without https.

So it goes like http://10.10.xx.xx:8123

The https causes certificate error locally.

1 Like

@skgunputh so your homeassistant works with http and https ? Do you have certs specified on configuration.yaml ?

1 Like

after strugling with this same issue I finally find out what was happening: you have to grant Device Location to the app , and, Device Location HAS TO BE turned on for the app to understand that the device is at home

1 Like

Thank you for this. I couldn’t figure out why the HA app wasn’t reading my current Wifi name… This was it.

How you know HA companion is connected to your SSID when at home? What to check?
I have set HA URL to the nabucasa one and the internal URL to my local IP…
In this way if i use cloud disconnect service, my app would connect to the internal URL, but it fails…

It’s in connection in the app… Tap your name in the settings and it will show you how you are connected either external or internal URL

Sorry but I cannot find it… can you share a screenshot ?
If I tap over my name in connections it says only I am connected as maurizio… Not as external or internal…