Connecting UPS to Home Assistant

I know there are TONS of articles on this, and I have read many of them and still have trouble.

Ultimate goal: Connect my APC UPS to Home Assistant to monitor for power outages.

Setup:

  • HassOS running directly on Raspberry Pi (not docker)
  • APC UPS plugged directly into the Pi via the RJ45 to USB cord that came with the APC
  • Within Home Assistant: Configuration -> Integrations -> Add integration -> Network UPS Tools (NUT)

The setup instructions for NUT are here apparently: https://github.com/hassio-addons/addon-nut/blob/c022f38864d44a7a88b9dfcc3a49dc8afc4acb20/nut/DOCS.md

But, just putting in host as a0d7b954-nut as the doc suggests with username nutty and password changeme, I get the error Failed to connect.

Now, it seems like I need to actually run the UPS server somehow, but I can’t figure out how.

Any tips?

Additional info:

  • I tried SSHing into the pi running hass.io using ssh [email protected], but I get connection refused. This seems like its own issue…
  • I shut down the pi, unplugged the RJ45, and plugged it directly into a monitor, but when I log in using root, I get an error saying home assistant cli is not running. Jump into emergency console. This scared me because googling this error just brings up a bunch of people who had dead SD cards… I plugged the pi back into the network and out of the monitor and everything started up fine, so the pi isn’t dead thankfully.

UPDATE:

I ended up getting it to work following this guide, which connects the UPS to my Synology NAS (which I happened to have - not all will…). Now it works just fine.

UPDATE 2:

Wait… was this addition to the configuration.yaml (below) the only thing I was missing when I had the UPS plugged directly into the pi? That would be frustratingly simple…

mode: netserver

1 Like

If you want to connect the UPS to your RPi running Hassio, then here is how I got it to work:

1 Like