Connection impossible on one device


I have a Samsung SM-A320FL and the Android app doesn’t work with my remote url (with a LE certificate).
When I put the external address, it asks user/password and after it says Cannot connect to Home Assistant.
It works with Firefox/Chrome on the phone, perfectly on others devices (Pixel 3, iPad, browser…)
I tried with an other Android App, HAClient, and the error was that it can’t get a temp token. Maybe it’s the problem ?

I recreate .storage/auth* files but same problem. I even reset the phone (always with the officiel Samsung ROM)…
Maybe someone have an idea ?


I have quite the same issue: with the app I can connect from tablet but not from phone, but with browsers i can access from both. The error is the same you reported, after I enter my credentials. The issue is the same from inside or outside my network, but it is present ONLY IF it is active SSL access, no issue if I don’t use certificates on server side.
Your post is quite old, do you have updates? Somebody have any ideas?

are you using a valid SSL cert?

Yes, of course. With this SSL cert I can connect without problems, from inside or outside my network, using any web browsers (tried firefox, chrome and even “konqueror”, the linux kde browser) from phone, tablet & PC; I can also connect using the Home Assistant App (android) from my tablet…I can’t connect (but I reach the logon page and I can type user/pass, however, so the SSL validation step is already completed) just only from my phone.
More: if I type a wrong password, HA reply me with the error, but if the credentials are ok, HA reply with the “Cannot connect to Home Assistant” error and definitely stops me.
More more: if password is wrong the logon attempt is traced in the log, but if credentials are ok and reply with the “cannot connect…” error, in the log there is any trace of the event.

i found that Fully Kiosk broking something. i dont know what, but when i runned by public proxy it started to work.

I remmoved everything, and could connect before started kiosk mode.