Connection issues despite new router

Hi guys.

I have a problem with two motion sensors from Aquara. I recently added a router (ZBDongle-E) and yet the sensors are strenuously trying to connect to the bulbs, with which they have a very poor connection. This results in the sensor detecting motion, but not reporting it to the server, which results in having to wait 45 seconds for another cycle.

I don’t know what causes it in the first place:
Poor connection with the bulb (they are about 2 meters apart)
No desire to connect to the new router (They are about 1.5 meters from each other)

My wifi operates on channel 1, the zigbee network on channel 15. There is no significant interference from neighbors.

I’m uploading in pictures a snapshot of the entire network + problematic devices.

I’m a bit of a layman in homeassitant, I’d appreciate a hint on what diagnostic steps I can take, or what to do/buy to improve the situation.

I’m using ZHA for Zigbee, DellWyse computer with homeassist virtual machine on proxmox. The main USB dongle is Conbee2 on long USB 2.0 cable.

Where were these devices when you first paired them?
Zigbee devices can stick to the best connection there was as they were paired, for quite a while. They do seem to re-arrange themselves once they’ve in a new location for a while though.

If you haven’t already, maybe try (re)pairing them while they’re in their usual location.

Zigbee channel 15 is awfully close to Wifi channel 1 - I’d certainly switch my Wifi to 11 (as it’s a lot easier than repairing all the Zigbee stuff!!)

Channel switched to 13. We will see if that helps, 1 is really close to Zigbee 15 i trusted blindlessly to ChatGPT lol :wink:

1 Like

The device is Aquara Motion Sensor. How the hell can i unpair it? I tried holding the reset button on the side of the device, and sending “reset_fact_default (id: 0x0000)” command from ZHA. Nothing works, the sensor won’t go unavailible / offline or anything…

Unpair it?
With any zigbee device I’ve used, I could just go through pairing again without any unpairing first.
You could always remove it from ZHA though, I’m pretty sure that’d do it.

I don’t use ZHA, but in Zigbee2MQTT you can define the device to pair with (i.e. pick the controller, or a bulb, or any other router). Not sure if ZHA has that ability.

Good point… you can do similar in ZHA by going to
Settings>Devices & services>ZHA>Devices>Select the device to pair through>3 dots>Add devices to this device.
I’m pretty sure they’d still re-arrange themselves after a while though.

Ok, the device just malfunctioned. Replaced it and now working like a charm.

Thanks for help :wink:

1 Like