Connection lost: reconnecting issues on 2024.3.0 and onwards

Is anyone else having issues with Home Assistant since updating to 2024.3.0 and above

Everything works brilliantly like it has, and when I try to start 2024.3.0 all appears to go fine until it loads everything and then it just gets stuck on Connection lost: reconnecting…and gets no further.

Tried rebooting the VM and the whole machine it runs on…but nothing changes…yet when I rollback (proxmox snapshot) to my prior backup…which is 2024.2.5, it loads instantly and has no issues…this is the same on every device trying to run HASS including, Echo devices with FKB, phones and computer browsers.

Just had a quick scan through the breaking changes and couldn’t see anything that would affect me…at least not in this way…so wondering if I am alone in this.

Interestingly, as soon as its updated, the first startup of 2024.3.0+ is fine, but then when it’s restarted, that’s when the issues crop up

The next thing to try is a brand-new build with zero config at all.

1 Like

and it’s fixed…for now

no idea why this affected things or why it wasn’t an issue before…but after reading a post elsewhere I made some changes in Settings>System>Network

Where my router (UDM SE) has set a fixed IP for pretty much all my devices including my instance of HASS, HASS itself had always just been set to automatic and has always worked without issue.

But read elsewhere changing this to a static IP will help…and doing so has fixed the issue…no idea why and more importantly why this is an issue 2024.3.0 onwards

Hope this helps someone else out if they experience the same

This is most likely something to do with your HA instance (an integration, add-on, HACS component or YAML). There are no issues with HA DHCP instances and Proxmox. Your ’ solution’ is a workaround, not a solution. I suggest you try to resolve the issue instead of working around it.

Workarounds come back with a vengeance.

1 Like

i totally agree with your thought process and I checked all of the logs and no error was showing…it starts up exactly the same as it does with 2024.2.5 and then goes to reconnect…it just makes no sense…I have snapshots kept in case it crops up again and will continue to dig further…but is is very odd that it only happens on 2024.3.0 and onwards and that there were no breaking changes mentioned AND no one else seems to have the same issue

I had a problem this morning, I started the update and after a short while I got a message telling me the update was no longer available. Now not much works on the display and it tells me that configuration.yaml is no longer available. I can’t SSH to the machine from another computer or use the terminal. The absence of the configuration.yaml is preventing me from doing anything.

This is a Raspberry Pi image written to a Pi 4 (with an SDD) and 8GB RAM.

This was a new installation I started a couple of days ago, my previous one failed with a corrupt Micro SD. I shut it down as I was going to loose power and it would not restart as the file system had become corrupt and it looked like Docker couldn’t start the image.

I tried to get this recorded quick in case it was a bigger problem. Any suggestions as to a fix.

If I was in your shoes I would try to troubleshoot. Create a VM copy, rename the HA instance and get the HA net as it was when you experienced the failure. Reboot and see what happens. If problem persists start with deactivating one-by-one HACS components, then add-ons, then integrations.

I would also look into configuration.yaml in case you have entries which have been migrated to the UI.

Lastly if all above fails start disabling automations, scenes, helpers, etc one by one.

1 Like

I can’t do anything with the live instance, it won’t shut down or restart because of the absence of the configuration.yaml. It only lets me see the Home Screen and I can turn my lights on and off with that. The Logbook and To do list pages are the only ones that show.

I can get into settings and I can see a message that says:

The following integrations and platforms could not be set up:

    intent (Show logs)

I can’t get to the logs via the Web interface or via SSH, to see what the problem is.
I was really just wanting to record something in case it was a wider problem.

All I have really done is the install, that set up my lights, adjusted a few visual things such as adding rooms. I have added HACs and installed a couple of devices from it.

I have physically turn the Pi off and restarted and that hasn’t resolved it.

So I think starting again from the down loadable image should get me back to working more quickly and I’ll use a different SSD in case that was the problem.

Thanks for the suggestions though.

Sorry Mike my comment was not for your installation. You are running a Pi which I do touch as I do not consider the platform production grade.