Connection problems / errors with ZHA

Hi all!

We did a little renovating on Monday in the house and some lights were not available because we needed them to move. Tuesday evening we plugged everything back in and also added some new lights(2 hue spots).

So yesterday(Wednesday) the errors and other stuff began to start. Lights didn’t respond, battery-powered devices weren’t updating their state so automation based on the sensor were not working anymore, etc etc etc. After checking the logs I saw something about duplicate ids with the corresponding id, never had I this kind of error. After some searching in Visual studio code with the id that supposedly was duplicate, I couldn’t find anything. did a integration reload, got the same errors but with different ids. Again, couldn’t find the duplicate id.

I really didn’t know what to do so I tryed to update HA to the latest version. Did a quick “Check Home Assistant configuration” and waited for it to finish. After 20 minutes it gave an error saying that the integration ZHA couldn’t be find. What? I did the update anyway…

After updating everything worked pretty great. No errors of duplicate ids. But now I have a lot more entities in ZHA than before. Never seen these and don’t know if its a update thing or a bug thing. Does anybody now?

After running the new update for a couple of hours the ZHA is buggy, some lights don’t appear as on, some won’t react to automations, remote controllers not working so i cant control my lights. And then after a integration reload everything works fine…for now.

Whats happening? And how can i figure out what the problem is? Everything worked perfectly before.

So I’m running on the latest HA and using Conbee II stick with ZHA.

The errors/warnings that now appear are driving me nuts:

ERROR (MainThread) [zigpy_deconz.uart] Lost serial connection: device reports readiness to read but returned no data (device disconnected or multiple access on port?)
WARNING (MainThread) [zigpy_deconz.zigbee.application] No watchdog response
WARNING (MainThread) [zigpy.topology] Cancelled topology scanning task

And a lot of these warnings:

WARNING (MainThread) [zigpy_deconz.api] No response to 'Command.aps_data_indication' command with seq id ***

Help me out!

Hi, did you solve it?
What version did you come from? A pretty old one? The serial error, anything about that one? Have you unplugged the conbee as part of you moving around, maybe using a new USB port? Not sure about the error mention deconz? Do you have deconz installed? (Neither deconz supervisor or deconz integration should be installed)

No I did not solve this.
I think ZHA is using deconz API. That’s why you see it. The weird thing is is that after een update of HA the errors disappeared. Still having allot of warning logs(360+) about a device:

Logger: zigpy_deconz.api
Source: /usr/local/lib/python3.9/site-packages/zigpy_deconz/
First occurred: February 14, 2022, 09:17:19 (379 occurrences)
Last logged: 09:22:06

No response to 'Command.aps_data_indication' command with seq id '0xa4'
No response to 'Command.aps_data_indication' command with seq id '0xec'
No response to 'Command.aps_data_indication' command with seq id '0x84'
No response to 'Command.aps_data_indication' command with seq id '0xf9'
No response to 'Command.aps_data_indication' command with seq id '0x5b'

ConBee/RaspBee user posted similar issue →

FYI, there are also known issues with ConBee USB adapter sometimes needing to be unplugged and reinserted after a restart of HA. If that is the case then might be a good idea to also report to (?).

However, even before start troubleshooting recommend upgrade ConBee/RaspBee firmware and follow the best practice guidelines here → as that will at the very least probably reduce most errors and failures caused by a noisy environment due to RFI/EMI interference. Even if it is not the root cause for this issue, trying to reduce sources of interference should hopefully help further troubleshooting.

Short summary of best practices on how to achieve a stable Zigbee setup and a robust Zigbee network mesh:

Zigbee and especially the Zigbee Coordinator are known to be very susceptible to Radio Frequency Interference (RFI) / Electromagnetic interference (EMI) caused by different signal interfering sources, so most general tips is to try to reduce interference meant to be taken seriously and it is very important to follow those best practice guidelines even if they may sound silly at a glance.

A lot of ZHA and Zigbee2MQTT users and especially those with ConBee/RaspBerry based Zigbee Coordinator adapters have posted in the Home Assistant community forum reporting with similar symptoms or other types of connection problems with Zigbee devices and for many of those issues the root cause turned out to be RFI/EMI interference and the users reported that the problem was resolved by simply getting both the Zigbee Coordinator and devices a bit away from all possible sources of RFI/EMI interference.

  1. Upgrade to the latest firmware on the Zigbee Coordinator adapter (whichever adapter you have). For ConBee/RaspBerry see:
  1. Connect the Zigbee Coordinator adapter to a long USB extension cable to get it a bit away from computer and peripherals.
  2. Connect the Zigbee Coordinator adapter to a USB 2.0 port (or via USB 2.0 hub, because USB 3.0 ports do cause interference).
  3. Shield any computers and USB 3.0 peripherals like hard drives by using metal enclosures/cases for computer and peripherals.
  4. Make sure that your Zigbee Coordinator adapter and devices are not close to your WiFi Router or any WiFi Access Points.
  5. Zigbee devices do not have long-range (or good radio signal penetration) on their own so begin by successively adding more always-on mains-powered Zigbee Router devices (a.k.a. Zigbee signal-repeaters/range-extenders) closer to the Zigbee Coordinator adapter and then in each room building outwards to form a stable Zigbee network mesh before adding devices further way. Note! Remember that Zigbee Router devices should be installed with permanent power so they are always available.
  6. Afting adding always-on mains-powered Zigbee Router devices pair all the other devices (Zigbee end-device devices) such as example battery-powered sensors where you plan to have them permanently installed and do not move them around afterwards.
  7. If still have issues change Wi-Fi channel(s) on your WiFi router or WiFi access points to do not conflict with Zigbee →
  8. If still have a problem then consider changing Zigbee channel to channel 25 at the risk of then no longer being compatible with older Zigbee devices, also noting that changing Zigbee channel could mean that have to re-pair all or some devices.

PS: I appreciate it if you guys give a thumbs up to this PR if these guidelines help you →


Just want to add I have the same warnings as you.

Logger: zigpy_deconz.api
Source: /usr/local/lib/python3.9/site-packages/zigpy_deconz/
WARNING (MainThread) [zigpy_deconz.api] No response to 'Command.aps_data_indication' command with seq id

Every 2 mins in the log after I updated to 2022.2.6 from 2021.12.10 HA Core on Docker. Did not have the warnings before the update, Zigbee network have been solid for over a year. Did a downgrade back to 2021.12.10 but the errors remains now in that older version to… Just did a upgrade to 2022.2.7 and warnings still there every 2 min.

Tried reboot the hostserver, changing the usb cable to the Conbee. I have the latest FW on the Conbee so cant upgrade it. Stick and wifi-router are not close so cant be that.

Will try a couple off other stuff and see if it helps. Will let you know if I find a solution. Hope you figure it out.

@Hedda Thank you for writing this down. Have checked everything. Just updated to the latest firmware and still the errors come up.

  1. check
  2. check
  3. check
  4. check
  5. it’s 1,5m away from the router. can’t change this.
  6. do not have a big house. so everything is within 10-20 meters
  7. didn’t change
  8. its on a different channel
  9. pretty high risk. don’t want to re-add 24 devices.

20/24 devices are routers.

I can suggest using ssh and see if you still have a core_deCONZ addons.
Before installing zha I used to use deCONZ and after removing the integration from Hassio, the deCONZ icon was still on the left menu of Hassio.

Well I uninstalled deconz via ssh and everything was working without any problems.
hope this help.