Connection refused after updating HA to latest version

So I flashed the Raspberry Pi 3 Model B and B+ 32bit onto my SDcard. Balenaetcher says its successful and I mount the card in the Pi.
I browse to the IP of the raspberry and it says “Preparing the homeassistant , wait 20minutes.”
So I wait and after a while I can reach the lovelace interface, I see there is an update so I update it and after updating I cant reach the webpage anymore. Says Connection refused.
I tried hassio.local but same thing, cant reach it no matter what so I cant check the logs.

This started happening pretty recently, my old installation had the same issue. It was running Homeassistant and after updating to a newer version it just said Connection refused so I thought I broke the config with some addon/line of code. But after flashing the sdcard it just says the same thing when updating the core/homeassistant.

I checked my router for any strange settings but all seems fine. What am I missing?
Tried several browsers, same thing.

Hi Roger, has your problem been solved? I have similar issues.

First off… try a power off, power on, and WAIT. SD cards can be slow. Updates involving a lot of IO can be super slow. Next, can you ssh in and see/edit/grab your configuration files? If so, save those somewhere local. Is the IP address still the same, or did it change? You may need to scan your network/check your router to find your home assistant IP address. Try to set up a static IP with your router. If you still can’t reach the webpage, but you can ssh in… can you remove the last thing you added to your config files and try a restart? If all else fails, you can try to reflash with the latest version.

To be honest, my initial ventures into home assistant found me hitting similar issues where an update or a change in a config file (or adding a bunch of random integrations without checking configurations <-- yeah, it was probably this…) caused to not load, leaving me without ssh access to config files and no good way to get in and debug things – and I love debugging Linux, so this was a bad thing.

I ended up building raspbian lite, and installing home assistant into a python virtual environment, setting up HACS, setting up node-red manually, and doing the whole thing the hard way – precisely because I never wanted to have things just stop working and leave me without any way to dig in and get into low level debugging at the OS and application level.

Now… I’ve been doing Linux and UNIX for decades, so for me this was a no-brainer. It was still a challenge, and I found a surprising lack of docs or guides covering a complete manual install including things like HACS and node-red… however, IF you’re not intimidated by Linux and the commandline, it’s an option to consider.

I’m experiencing the same issue. It’s appearing at it’s regular IP address on my network, but I can’t SSH or use Samda to look at the files, and it’s refusing all connections. I can’t load lovelace or anything. No idea what to do.

Hi Tim, solved this issue by replacing my SD card and perform a fresh HA installation. I bought a Samsung EVO Plus 32GB micro SD, no problems anymore. Further, be very careful: any hard shutdown could ruin the card.
Next to that, make sure to limit the amount of items recorded in your configuration.yaml.

Yeah, I’ve swapped out to a new pi4 and a new SD card. Looks like I’m starting from scratch.