Connection to Nefit Easy failing

Tags: #<Tag:0x00007f73974087f8>

I have been trying to get my Nefit Easy connected to HA. I used things from here: https://github.com/ksya/ha-nefiteasy and I copied thing to the proper folder.
I have things as follows:
nefiteasy:
devices:

  • serial: ‘123456789’
    accesskey: wwwwxxxxyyyyzzzz (no numbers so no quotes)
    password: ‘xxx16yyyyyy’
    name: Nefit Easy
    min_temp: 15
    max_temp: 21
    temp_step: 0.5

After restarting HA I keep getting this message:
Nefit password error
Invalid password for connecting 718923280 to Bosch cloud.

I double checked…triple checked and now it is driving me slightly up the wall as I fail to understand why this message is being shown.
Any pointer in the right direction is highly appreciated.

Thanks in advance!

I’ve been more testing and I think the access key needs to have this format using hyphens
wwww-xxxx-yyyy-zzzz
However, the message still keeps popping up. Some say it is related to this
MinProtocol = None
CipherString = DEFAULT
But where and how do I set this in hass?
I tried creating a openssl.cnf in the ssl folder of homeassistant but that didn’t work either.
Any thoughts?
I have seen others working happily with it…I want that as well :slight_smile:

Thanks!

Regularly the server connection appears to be lost, and then restores after a while. So not very stable but it works.

My config looks like this:

nefiteasy:
  devices:
  - serial: '123456789'
    accesskey: !secret nefiteasy_accesskey
    password: !secret nefiteasy_password

accesskey look like this AAaaBBcc1245CdEf without hyphens

Leon,

thanks for looking into this. However, the issue is still there. I have tried with and without hyphens but it keep telling me the password is wrong. I also have the app so I know for sure that my password is correct.

Ron

The fix has been found. Setting of the quotes was indeed the issue. I have now been able to connect the Nefit Easy
I also purchased a small box that connects directly to the Nefit and provides its stats as well.
Issue can be closed