Console Access on OVA (was: Password for OVA?)


I have installed the ova file on my VMware ESXi 7.0 and it runs nearly fine.

But for some add-ons or other stuff I need to have console access.

On the VMwar remote console I can log in with root without password, but it brings me only to a shell where I can use the ha command.

But I really need proper console access through bash- for backup purposes and so on.

*How do I get console access as root on the appliance?



HA OS runs a minimal OS using Buildroot, so many traditional Linux commands don’t work. You can install the SSH & Web Terminal add-on from the store to do some console work instead of using the HA shell.


Well, the ssh add-on offers indeed ssh-access if configured correctly.

But it is inside of a Docker container… so I am not able to perfom needed steps.
For example, having access to the database.

There is no sense in a dockerizedd version of terminal/ssh as long as I can not leave the container (which is not possible by purpose…).

You could use a different database like MariaDB and then you can access it via a Web interface.

Would you I agree if I tell you this is not really an appropriate solution?

I mean, where is the point using an external database for an appliance which is meant to integrate everything? The 1-wire was just an example. Check the add-on docs, there are many add-ons which mention shell access for configuration.

However, I see the idea of HA is to have everything in the GUI which is really good. In this case you should try to either not accept add-ons which need console access or have a minimal (busybox-like) shell to allow such steps.

As of now the appliance can only be used as testing, not for production.

So looks like I have to go and build if on my own based on a full-flavored Linux.


One of the main features of HA is its expandability, with hundreds of official and unofficial add-ons to expand the capabilities of the software, so no, I completely disagree with you.

Take 5 mins, install an external database and get what you want. I’ve personally been using MariaDB for years now and find it excellent and very reliable.

As far as being a production product, you’ve provided no information about you use case so it’s difficult to know if HA is suited to your particular situation.

I have 3 HA instances running, 1 in my home with close to 100 lights, switches, temp sensors, location tracking, cameras etc. 1 instance in my business monitoring and controlling heat lamps, dining room fans and lighting, motion sensors and alarm and 1 instance in my elderly parents house who primarily use Alexa to activate scenes and scripts via voice command to turn things like lights and their TV on and off, control the AC and so on.

So is it production ready? Absolutely. Does it suit your specific use case, no idea - you’ve not provided why it wouldn’t work.

please differentiate between HA as such and the particular OVA installation. I totally agree with you about HA and it open-ness itself.

Same, it does not make sense to request an additional MySQL instance/ VM when everything is to be designed on a single instance like this OVA appliance.

The other points I absolutely agree with you as it is really, really very nice to have such an open architecture. And regarding production I just want to clear: HA itself appears to be production-ready. Just the OVA instance is not (first, it can not deployed easily on ESXi second it lacks functionality like shell access).

What I am saying is HA-OVA is unfortunately only a criplled version of HA. The idea of an easy deployable version is great. There are just some things which have not been though until the end…

BTW: I have an ESXi 7.x instance running here and I will have it running for the next couple of years. In case you need to get access to such an instance for development, let me know.

I haven’t used the OVA image myself, but as far as I am aware it is the same HA OS image as the QCOW2 image I use in Proxmox - the full Home Assistant Operating system as well as running Home Assistant.

It’s not a crippled version of HA, it’s designed to be a “plug and play” solution for a new user who has no Linux experience. Using HA OS, you don’t need any, by design. It can also be installed as a VM like you are doing, I myself run 2 instances uses HA OS using Proxmox.

You have other options if you want a full Linux Distro. You can run Container, Supervised or Core. All of these options will give you OS access to do with you want. The caveat using Supervised is you must use Debian 10 as well as not installing other software directly to the OS - installing docker containers is fine though. See HERE for the rational.

Perhaps you would be better off running a Debian VM and installing Container, Supervised or Core.

Open a session to the VM, your hypervisor supports that.

Hi all,

I really appreciate all your efforts to show me a way to access the console. Still, we are going in circles here. I am not looking for a particular workaround for a specific task.

I try to explain it in detail. The GUI is absolutely great stuff. The appliance is generated for easy deployment and short installation time as well as to have everything in one place and matching everything. Have a perfect base for updates and so on. Good job, really!

Still, there will be some tasks which has to be performed on the command line. Take the 1-wire add-on as an example. Of course I can create a second VM to workaround the issue with direct database access. But there might or will be another add-on which requires console access for whatever task. So then the external database does not help. I will still need console access then.

So what I am looking for is how to get console access to perform the task needed for the 1-wire device. Which acts as an example!

The link from @ludeeus provides a lot of good information. It states:>

You can also access the Home Assistant Operating System via a directly connected keyboard and monitor, the console. To log in to the physical console the username is root, with no password.

Indeed I tried this. This is the result:

So the topic might be misleading. I do not need the password. I can login as root without password. But I only have limited access through the ha console. I still can not do the steps needed.

Enabling ssh throug add-on does not allow me to leave the docker image. So not helpful, either.

From my point of view it is a great idea to completely remove shell access in order to have a more stable environment. In this case it was not thought through to the end as there are (and possibly will be) add-ons which require console access for whatever reason. This is why I called the ova “crippled” as it refuses to use add-on which require console access for configuration. Even if it is advanced configuration.

I just found the database add-on to do it for my particular issue. Still, the question for shell access remains.

Type login

The 1-Wire integration is setup via the UI. What am I missing?


Oh man!

That’s what I was looking for so desparetly. Thank you so much!

Look here

Ok, marking it now finally as solved!