Constantly loosing zwave nodes

Thanks! I am runing Proxmox V Server with HASS runing as a VM. In Proxmox it is possible to configure USB passthrough and dissable USB 3. I am not sure of the details SW vs HW but configured it. A consequence was that all nodes needed to be re interviewed??? (takes a lot of time). If this turns out to not work I will buy a 700 solution. All in all I am tempted to move to Ziqbee and /or WiFi devices as I have had nothing but trouble with Z-wave. (Vera, HomeSeer). Loosing nodes, ghost nodes, malfunctions, inclusion problems etc. (today I have some 60 nodes)

I had a really good run with the Aeotec Gen 5 once I figured out the yellow port issue. I think my zwave network ran for the better part of 18 months without issue until I upgraded to Zwave 7.

I implemented the above. All nodes are back now … But I lost one node today so to early to say… Since USB 2 hub with power is difficult to find I think i will go for Aeotec 7 …

I’m running Aotec Gen 5 (not +) stick on a non-powered USB 2.0 hub without problems. It’s plugged in to a raspberry PI 4.

I did have similar problems previously that seems to have been solved by the latest z-wave js server updates (devices would go “dead” quite often. After they introduced the z-wave ping I could most times get them back online by pinging them. Z-wave heal had a bug that it would never finish, so although that also got most nodes back online I could only do it once before rebooting).

After a complete reboot of your host (not just HA), how long does it take until all nodes are back up? (settings → devices & services → “configure” on Z-wave JS → upper right and "network connected XX devices (XX not ready))

hi… thank you for responding… It seems the problem is solved as after configuring the usb port in proxmox to be usb2 the system has been stable for more than 24h with all nodes ok. I have also ordered the aeotec usb stick 7 to upgrade to a 700 system…

For me it is not acceptable to rely on pinging and healing as my security system is dependent on HASS…I have a long history with zwave and i have experienced problems with different controlers (vera, Homeseer ++) all the time… I am now testing out Zigbee (15 nodes at the moment) and wifi nodes (5 nodes at the moment) no problems so far and very easy inclusion WITH NODE PHYSICALY AT ITS FINAL DESTINATION.
NB I will test the time to get all nodes back up but later as i can not take the system down now… and get back to you… What info will this provide?

I was hasty … There seems to be no easy way to migrate frome 5 stick to a 7 stick (Aeotec) … That means a full repairing of every node which is out of the question as long as there are other alternatives…

I am still missing nodes but very few and very seldom so I will get a USB2 hub and try that…

Anyone know a way to migrate from 5 to 7?

If you’re using Zwavejs2mqtt then it’s a simple backup of the stick NVRAM and restore to new stick…

1 Like

Thx… Can you please expand on that … how to do it…? I did purchase a 7 stick but was considering returning it… But then another bad thing happened which needs urgent attention: Upgraded ZWaveJS2MQTT to version 0.45.0 "LOST" both Aeotec and Dresden stick
I did see some posts that said the issue could be due to wrong instalation of z-wave JS and the add on zwavejs2mqtt… I have both Z-Wave JS (Current version: 0.1.65) and Z-Wave JS to MQTT
Current version: 0.45.0 as add ons and Z-Wave JS as integration. I will go through the instalation docs and see it it is correct as it looks strange to me
I am geting increasingly frustrated of the difficulties with achiving a stable and reliable Zwave network

In the MQTT control panel, Click the actions menu, select advanced actions, and you should see this screen, click on NVM management. FWIW, I create a backup after every time I’ve successfully added a new node

Thank you for beeing so kind to help… Unfortunately I can not reach the MQTT control panel after upgrading ZWaveJS2MQTT to version 0.45.0 . I suspect that there is something wrong with the instalation:
I have one Z wave JS integration where the server url is ws://core-zwave-js:3000.
I have one Zwave JS add on with host name core-zwave-js
I have one Z-Wave JS to MQTT add on with host name a0d7b954-zwavejs2mqtt

It seems to me that the integration should point to server ws://a0d7b954-zwavejs2mqtt:3000 ???

I have tried to re configure the server (in the integration) but it refuses to connect to ws://a0d7b954-zwavejs2mqtt:3000 with the error ! Failed to connect

CAN I reinstal the zwave JS integration and add on and the zwave JS2mqtt without loosing all the devices and nodes on thre USB Stic???

If I had employed your backupstrategy I would be better off now…

I don’t know much about that. I run in Docker and have HA in one container and zwavejs2mqtt in another. From what I read, installation issues like you describe are fairly common. Hopefully someone knowledgeable will be able to help.

Sorry but there is one unclarity. I have read that the structuring of data in the 7 stick is different from the 5 stick Do you positively know that this method will work for the Aeon 5 stick to the 7 stick?
I also find it strange that i can not find any guide or tool for this on Aeons site?

zwave-js handles the conversion of the NVM formats.

I have now introduced a USB2 hub between the PC and Aeon Stick 5. It has been running for 48hours and I still loose nodes. The easy way to get them back is to ping them. I have a Aeon 7 stick also but have not tested it yet. I do read in this forum that people are ALSO loosing nodes with this stick.

I think a solution could be to ping nodes automatically and regular or even better when they are lost. I do not however know how to detect when a node disappears?

I am sad that the system is not fully trustworthy and I am close to remove security functions from it.

The system has been runing OK for a while but to day when I added two new nodes and after rebooting the system I AGAIN lost nearly all my nodes :slightly_frowning_face: :

There seems to be many other experiencing similar problems like:

All non batery operated nodes has been lost. I tried to reinterview them but that has been going on for 24 hours without any results. I do have a NVM backup but I am not sure how to restore. If I press restore under NVM Management i get some warnings and then it ask for the file. Is this the file under store → backups → nvm → NVMxxxx.bin ?

This file is not accessible through the SMB share and I am runing the UI on a windows machine… AT the bottom of the Store its a Settings wheel. If I mark the backup file and press the settings wheel this menu pops up:

The green menu button is restore… IS THIS WHAT I USE to restore?? I can not find any documentation on this…

Can someone advice on what is the best and working strategy to get my system upp and runing… Is it to use the NVM backup? If so how is this done in detail?

I seem to have several problems with the Zwave network and nodes.

  1. I constantly loose contact with nodes (YES i am using USB2). They can be restored by a simple ping

  2. A loose all the nodes and or a large portion of the nodes from time to time. Either in connection with upgrades or adding nodes.

Anyone has any idea why this is happening?

How does you controller statistics look?
I would back it up using windows if possible, and update the firmware on it. Mine is FW: v1.2
SDK: v6.7.0.
Any repeating errors in the debug-log?


As expected i think as there is no contact with any node


I see the FW is old and the sdk much earlier version… Strange since i bought the stick some months ago?

In the zwavejs2mqtt log there is only a lot of value updates for the battery operated nodes (they are working)

That link does not exist anymore

What would be the best strategy. Should i upgrade first or should i restore the NVM backup and then upgrade ?.. I also have a Gen 7 so perhaps move over to that and restore NVM TO THAT

Due to incompatibility between the NVM for FW 1.1, SDK v4.54.0 and the current FW/SDK it WAS NOT possible to to use the NVM backup in Z-wave JS2MQTT! I might have worked if I had used the Aeotec tools and transfered to anothe stick but I did nor know so bad luck… I ended up with rebuilding the entire network which took me two days!!! My procedure was :

  1. Backup of NVM of the Gen5 stick inside HASS

  2. Upgrade FW to 1.2 and SDK to 6.7 with the Aeoteck tools (I took a backup using the tools for this and tried to use that but it did not work. I also tried to use the restore of NVM in JS2MQTT but did not work)

  3. Rebuildt the entire network by including all devices and go through all logic and automations (a large job)

  4. System is now stable and there is no lost nodes

  5. Learning is to take too many backups rather then too few and to keep FW up to date

Hi everyone. This is an old thread but with a problem stil there. A year has passed and the problem of loosing zwave nodes are stil there. I can not see that anyone has come up with a solution and it does not seem that other systems have the same problem… Any one know if there is a solution…
I am close to give up on Zwave in HASS as Zigbee / WIFI does not havce this problem…