Aeotec Z-Stick Gen5 ZW090 New Firmware Update


Aeotec released a firmware update for this Z-Wave controller yesterday the 17th Nov 2021. The link is here:

Confusingly, the article is titled Z-Stick Gen5+ V1.02 firmware update but is is for the Gen5 device to bring it up to the same firmware as the Gen5+.

As I had a spare Z-Stick that I’m about to use for my clean migration to ZWaveJS I decided to risk it. The software runs on Windows only and there are two components - the device drivers and the firmware installer. It may be possible to use the ZwaveJS firmware installer as well, but I didn’t try this.

The update only took a few minutes and after unplugging and reinserting the device, the most noticable change was the colour cycling LEDs changed to solid Green to indicate the charge state of the internal battery. On the ZWaveJS console, the firmware changed from 1.1 to 1.2.

As with any firmware update, you do this at your own risk, so it would be wise to backup the device first using the Aeotec software.


Surprisingly my stick is running about half a year, is a “gen5+”(not to confuse whit a Gen5-zwave+, both gen5 and gen5+ are zwave+) and I already had 1.2:

It also comes to my attention is says swave plus: no :face_with_raised_eyebrow:

Yeah, my Gen5 now shows exactly the same info as yours. This article seems to be saying that it’s up to the host software to implement security features.

Not sure why and no documentation on why but it’s been said that this value is not valid for controller and only valid for associated nodes. So “Z-Wave Plus:no” will show for all controllers

The Z-Wave+ property (and others) is derived from information about a node provided after joining the network. A controller being accessed over the USB serial connection doesn’t provide this information. From the HA point of view, there’s nothing special about the serial USB controller, and from the driver API all nodes provide the same properties, it’s just some of these properties are never set for the controller so they default to some value. It would require special handling by the application to ignore these fields for controller nodes.

In fact, zwavejs2mqtt does this and will not show these fields for the controller in a future release. Hopefully the HA UI will follow suit to avoid this confusion.

Thanks for the explanation, nice to have that cleared up.

Thanks, clear. Do I understand that zwavejs2mqtt is ahead of zwavejs in terms of development and possible device support?

I assume you mean zwavejs2mqtt? What is “zwavejs” in this question? The driver, the Addon or the Integration? Assuming you mean the integration, and in that case zwavejs2mqtt is always ahead in terms of functionality. From device support there is no difference, that depends on the driver version, which is dictated by which application you’ve installed and its version (Z-Wave JS Addon, zwavejs2mqtt Addon, zwavejs2mqtt docker, zwave-js-server, from source code, etc.).

Thanks for sharing that info.

I have just discovered today that mine Gen5 doesn’t support Secure S2 and smartstart :frowning_face:
source: Z-Pi 7 • Z-Wave 700 series gateway development board; Razberry 7 • Aeotec

Will this firmware bring support for that, otherwhise I will have to buy a new one.
Mine firmware shows version 1.0

I have no idea, the information on the Aeotec support site is very sparse. It just says that it brings the firmware up to match the Z-Stick Gen 5+.

The reason I was interested in it was that I was rebuilding my Z-Wave network from scratch last weekend to upgrade to Z-Wave JS. Apart from one device, all 38 nodes worked perfectly.

At first, do the backup before you start anyting with firmware upgrade.

It looks that S2 is supported after firmware upgrade, I have included Ring keypad V2 by using Scan QR code. :grinning:

I want warn you that on the first try after firmware upgrade that nothing worked but I think that it was due using path = Dev serial ID path (likely path was changed). I changed it back on ttyACM0 and everything worked again.

1 Like

I’m in the process of moving over from another hub to HA, and I just added my first device today. I also found no S2, much to my surprise, since I had it with the same device on the previous hub. Here’s a screenshot of my device info (below). Oddly-enough, it says ZW090/Firmware 1.1, but the device label says it’s a ZW090-A, which I assume is the 5+? What firmware for this device will give me S2, if any? I’d like to upgrade it before I continue moving everything over.

Screenshot from 2021-12-03 17-49-39

Zwave_plus will always show “no” for controller since this is not applicable/checked

Security only shows on nodes

Sorry - I mainly included that to show the firmware and model for the stick. I meant to include these screenshots as well from my phone. One shows the error I got when I included the ZW15R outlet, the other shows the outlet’s info.

S2 is provided by software(zwavejs) being used. Check you have recent versiin(after nov21 I believe) of zwavejs. If using HA addon for zwaveJS I think it may be behind so you need to verify zwavejs version it using support S2

No sure how 1.1 vs 1.2 wrote x firmware affect this. I think it have No affect but update is easy so maybe just give it a shot.

Also make sure you have S2 key in zwaveJS. I believe it automatically create in recent version but I not sure what version you using so giving info.

I have add-on 0.14.9 installed, which uses ZWaveJS Server 1.12.0, which appears to have S2 support, as far as I can tell. I’ve got the key in ZWaveJS - the add-on generates it automagically. Anything I may have missed in the config?

Sorry to take so long to reply back. It looks as if the issue is with S2 Authenticated. I have some S2 Unauthenticated nodes that assist to use encryption just fine. It may even be an issue with the specific vendor, as all my S2 Authenticated nodes are from that vendor (Leviton). However, they worked fine with my Hubitat. I’ve thought about just leaving then on there and using the MQTT bridge, but I don’t want to have to manually create each device in HA.

Just new to HA en got an Aeotect z-stick gen5+ since several days. I was looking on the forum because I was confused about the “Z-Wave Plus: No” too. So reading here, this is normal, but… I included my FGWPE/F-101, which according to the manual is zwave and zwave plus compatible, But when I go to the device I also see “Z-Wave Plus: No” there.


So, now I am even more confused. Is the Gen5+ not operating zwave plus at all?

Hmm seems Zwave plus is working, as I added a Remotec scene controller:

Happy to see that, but I don’t understand why the wall plug is on normal zwave.

The FGWPE/F-101 is not Z-Wave Plus, according to the ZWA database. The F-102 version of that device is though, according to the same DB.

The field will always show “No” for controllers, you can just ignore it. The Aeotec supports Z-Wave Plus.