Continuous mmc0 error -110 whilist initialising SD card

Reinstalling HA, on a RPi, getting lots of errors at the HA command.

Have tried 3 different SD cards all given same issue

What does it mean?


I have the same issue, also with a couple of completely new SD Cards. First they run fine, but after a few days the error repeats.

Setup: Raspberry Pi 3B with OS 5.10 and Home Assistant 2021.1.3

1 Like

As well as trying multiple SD cards, I even tried another RPi 4 - same issue.
SD card works fine until HA starts its automatic initial setup it seems - then bam! Loads of SD errors.
(FYI I’m using a Raspberry Pi official power supply)

I’m having the exact same problem! Fresh install on a Pi 3B worked fine until I ask it to reboot. Then I have those errors!

1 Like

Yep I also tried a RPi3 with a full refresh. The image loads find and shows the login prompt (on the directly connected screen). But in the background HA is busy initializing and then the mmc0 errors start occurring again.

Seems to be something fundamentally wrong in the HAS initialization script I think

1 Like

I think you are totally right! First boot works fine for me though. I’m able to go through the first setup, but as soon as I ask it to reboot, I get to the

Welcome to Home Assistant
homeassistant login:

screen on a screen connected to the Pi, but right after, I run into the mmc0: error -110 whilst initialising SD card and I can’t access it anymore from the IP_ADDRESS:8123 nor the homeassistant.local:8123.
Hopefully this can be fix sooner than later.

The above link suggests it could be something to do with the voltage setting used to read the SD card. While investigating this I thought I read only the RPi4 supports this setting so this mmc0 issue should not impact the RPi3 which it clearly does.

Finally up and running ! Brought ANOTHER SD card (the previous SD cards all worked fine for a couple of years and/or ran Raspbian ok).
This is the working on SanDisk Extreme - the others were Samsung Evo/Pro/Plus etc (all 32Gb)

Most odd

Any one have an update on this. Happening on two different hasio installs (rpi 3 and rpi 4). Both were running for a while and then boom both went down. Tried new cards and same thing. Ran a check on the cards, no issues – can mount them fine on a linux box and access everything.