Control TiVo box over telnet


Depends on what the friendly name of the switch is…

Youll need to change the friendly name in ha if it’s interfering with BBC news

or create a group with a different name and put the switch in the group - in the alexa app


This is truly amazing… I was just looking at harmony controls and now I don’t need one! thanks :slight_smile:


hi @Rich_Paul sorry for off topic. will you help me how i can send autoremote message from HA… please


Wow, I’m going to try if this works on Tivo in Sweden, although I doubt it.


Sure, what’s up?

You need to follow my other guide


Should work mate :slight_smile:


1 install autoremote on old Android phone. Thus phone will become your ir blaster

2 once installed you will be given a link on the autoremote app. Open this link

3 on the page you opened, click send notification at the top, and the message you want to send. Let’s say the message is ‘off’. This message will be added to the end if your unique URL which auto remote provides.

4 install tasker on your old Android. Set up a new profile with autoremote as the sensor, you’ll be given a box called configuration - this is where the message is read, so put ‘off’ in here.

5 now you need to set up the task that tasker will perform when this message us received. I used anymote… So when the off message is received, it will open the any remote app and click the button on whichever remote you have set up. I have added all types of remotes to anymote - TV, amp, anything that relies on sending an ir command.




I am new to home assistant but have Alexa and Virgin Tivo box. What you have put above looks absolutely perfect for what I am trying to do. I was going to purchase a harmony hub but it seems this could do all of this without costing me a penny. Would you fancy putting a step by step guide up for all us novices to allow to share your work and get the best out of this.

For info I have 4 TiVo boxes in my house , as I can identify them by there IP address is it possible to give them all separate names also so I could turn over Lounge Tivo or Bedroom Tivo etc etc

Thanks for all you hard work on this



Easy mate!

Box 1 E.g

switch youview_off:
platform: command_line
command_on: 'echo IRCODE STANDBY | telnet box1 ip 31339’
command_off: 'echo IRCODE STANDBY | telnet box 1 ip 31339’
friendly_name: Virgin off - box 1

Box 2 e.g
switch youview_on:
platform: command_line
command_on: 'echo IRCODE STANDBY | telnet box 2 ip 31339’
command_off: 'echo IRCODE STANDBY | telnet box 2 ip 31339’
friendly_name: Virgin On - box 2

There you go - just replace the ip with box 1,box 2…

That’s it!

Then set up a group for box 1 and another fir box 2…

If you copy all my switches 4 times and just replace the ips which each box ip…

Telnet is far better than a harmony hub as it doesn’t require an infrared command, or line of sight to the box… And it’s RAPID!



PS… Most of the instructions are on this thread…


1)install telnet on your pi - above - sudo apt-get install telnet. Connect to your pi using ssh - putty to port 22
2) get ips of all virgin boxes - install network scanner app on a phone and connect to the same network your box is on
3) copy switch code and replace each ip address with your telnet boxes

Before number 3 I’d paste your cmd straight on the cmd line, when it works use that for your on-cmd on your ha switch.

So paste this straight on you cmd line putty instance (once telnet is installed)

echo IRCODE STANDBY | telnet your ip 31339


Sorry should have said I will be installing this on a Windows 10 laptop not a PI

So far I have managed to install home assistant (with a lot of messing about) and got it to auto discover although it hasn’t picked up my Alexa


It seems it doesn’t get any easier, I tried to connect to my virgin TiVo box. However whenever I try to connect via telnet or putty tp port 31339 I get connection failed


I think there’s a setting on your TV box to allow remote access.

Turn that on


Settings - devices - network remote control


thanks I will have a look



It would seem that I am going to become a pain in your backside I have now connected to the box fine and using telnet have managed to change the channel ok

However when trying to do it via a command prompt using echo SETCH 144| telnet 31339 all that happens is I get the below and the channel doesn’t change

Welcome to Microsoft Telnet Client

Escape Character is ‘CTRL+]’



Let me do some tests and get back to you.

There is a space before the pipe in that code btw…


Right just tested mine - doesnt even work on the cmd line now!

echo SETCH 144|telnet 31339

But it does in home assistant which is odd! try adding it to into HomeAssistant now, see what happens.

Its odd that mine no longer works on the cmd line but does in HA…


Seem to remember that only one telnet connection can be made to the virgin box at once. That might be the isue for both of us as none of mine is working now lol not even in home assistant which is odd…

Might be worth switching the tivo off n on by the plug