Converting this plug from Tasmota to ESPHome

Wonder if any kind soul could help me out. I’ve got some plugs I’ve just hacked with tuya-convert and installed Tasmota on. I now want to convert them to ESPHome (needed to take offline to do tuya-convert as only have one raspberry pi). Question is it says to work out what sort of plug it is and make a config file from that but I have no idea how to identify it. It looks like this:

Any help would be greatly appreciated. I’ve had nothing but issues getting smart plugs into home assistant.

Maybe this info for tasmota supported uk devices can help?

There was no exact match that I could see, but maybe one is same?

The tasmota template can tell you gpio to use etc.

Thanks, nothing on that list seemed right but I did notice the thing was clicking constantly & managed to work out that the Sonoff basic setup had GPIO13 as the LED and worked out the clicking was it turning the relay on & off thinking it was the LED. Altered this and uploaded the ESPHome software thinking I’d risk bricking a switch just to give it a try and it’s worked so managed to add them to HA with working switches. Now gotta work out the LED and Push Button pins but it’s a start.
If by some miracle I work all this out and it works is there anywhere I can leave the info for others as these plugs are the cheapest ones I’ve found on Ebay so other most likely have them too


Maybe @blakadder can add the details to his site as a tasmota template? (In the case of simple devices with direct gpio/function mapping its quite easy to translate a tasmota template to esphome)

Hi Dan, would you mind sharing your esphome yaml for this XS-A14 smart socket please. It might just save others some time working out all the GPIOs. Thanks

Hi Bill, I have just figured out the settings for the XS-A14 UK Plug Socket . I have submitted the template on its currentlyl awaiting approval. I have tested and its working fine on my units. In the meantime here’s the Tasmota Template, im assuming your using Tasmota?

{"NAME":"NETVIP XS-A14","GPIO":[37,0,38,0,0,17,0,0,39,21,0,0,0],"FLAG":0,"BASE":18}

I hope this helps, Goodluck!


Sorry i am using esphome. do you have the .ymal file or it there a way to convert from tasmota?