Converting Tuya based AC to ESPHome not working

Hi all,

I just installed a mini split AC that has a small board with Tuya running on it to enable remote control. I removed asap and wired up a D1 mini 8266.

Initially I was having issues using GPIO13 and GPIO15; if I connected those to the mini split, the ESP would not boot correctly. So now I connected the existing RX and TX lines onto the RX and TX port on the ESP. Those are GPIO1 and GPIO3. Now the controller powers on as it should but the Tuya MCU I configured does not show any data. The logs give the following line: “[E][tuya:434]: Initialization failed at init_state 0”

I have some experience with ESPHome but the Tuya MCU is new to me and I cannot find a lot of information on how to use it. I understand I configure the UART bus and enter Tuya in my .yaml. When the machine turns on it polls and lists all the possible datapoint which I can then configure to command.

But without a MCU response, this is impossible. I tried switching the RX and TX gpio’s, tried setting the baud rate to 9600 and 115200 but none of this works. Anybody here that could help me along?

This what I added to the default ESPHome .yaml file

# uart config
  rx_pin: GPIO3 #RX pin on D1 mini
  tx_pin: GPIO1 #TX pin on D1 mini
  baud_rate: 115200

# Tuya MCU connection

You have tuya: indented, it shouldn’t be.

Maybe you should start from that. What AC, what kind of board?