Copying in files to custom_components

Hi guys
im trying to copy in a folder to the custom_components folder - the new smartlife integration as located here:

i am logged into the ubuntu machine but the folder is root only so i cannot copy the directory in

i managed to copy it into the main homeassistant folder

the root previalages are driving me crazy… am i missing a simple trick?

in the mean time i tried to copy it in via command line and messed it up by copying the files from within the smartlife folder into the custom_components folder… so now i have a mess of files that are not in a correct smartlife folder…

i would recommend that you use the hacs method (also outlined in the page you posted). it will save you from mistakes and headaches. and you’ll also end up finding other cool goodies.

however if you really want to do it yourself, i’d recommend you use samba. if you’re not familiar with it, it’s an add-on that is not only great for this, but also a vital recovery tool if you ever screw up your config yaml.

1 Like

How are you running HA? This doesn’t seem like a supported installation method.

Also, any specific reason why you want to integrate it that way?
Are you aware of the possibilities to run these devices local with local tuya?

its running in docker

1 Like

i tried LocalTuya but it didnt seem to work very well for me…

thanks for the heads up - i managed to install via HACS - i didnt see that before

any advice on the LocalTuya… even with this new implemenation its not robust for me…

TUYA in general is not great, regardless what route you go. You can thank TUYA for that. Their partners don’t follow the TUYA standard, so your mileage may vary depending on what device you buy.

1 Like

you were seeing reliability issues with localtuya? I have the tuya and localtuya running simultaneously. I haven’t had much reliability issues with localtuya, but it doesn’t support all of my devices, so I use tuya when necessary… I do see more flakiness with the tuya integration. Tho more latency than outright failure

very often it doesnt turn the light on the first time, but on 2nd click it does

I have the integration restarting every 6 hours which helped it a bit, but its just not robust enough

i have used shellys in the past and they seem robust so thinking about swapping the UK 3pin plugs out to these:

and instead of using dimmable LED lights in a front door fitting, im thinking about going to this with just standard halogen lamps

I’m definitely not seeing something like that. is that happening with all your tuya devices?

i only use about 4 regularly, they work 90% of the time, but just find it annoying when it doesnt…