Core 2024.6.x Alarm Panel Fix

Hello everyone. Not sure if this belongs here, but I couldn’t think of a better place to put it. It seems that with the HAOS Core 6.x update, it has broken the alarm panel functions for “arm home” and “arm away” functions in the lovelace card whereby it now requires a code to be input. I have tested this with both my RingMQTT and Aarlo integration and both are broken now due to this issue. Request fixing Core 6.x to fix the alarm panel entity discovery to set code_arm_required to false by default like I believe it was before.

There is no core 6.x. please correct your post.

Also not a feature request. Moving…

And aarlo and ringmqtt seem to be custom integrations. If they are, ask there.

1 Like

Sorry, by Core 6.x I meant to say any of the Core updates so far within the “6” major revision (“2024.6.x”). This issue only occurred when I updated to HA Core 6.0, and 6.1 did the same thing. All else being equal, I moved back to Core 2024.5.5 and it resolved the issue, leading me to think it was an issue with the HA Core update.

If you mean 2024.6, damn well say it.

1 Like

Thanks for this workaround! Is there a function I can add in that yaml for code_disarm_required? Or does removing “code: !secret alarm_code” in the yaml code work for disarming and arming without a code in the UI? If I’m using HA I don’t want to have to use the code at all like I can with 2024.5.x versions of core.

Thanks

Share your current alarm config.

No special config in my config.yaml file. Just using the basic alarm panel provided by the lovelace frontend:

square: false
type: grid
columns: 1
cards:
  - states:
      - arm_home
      - arm_away
    type: alarm-panel
    entity: alarm_control_panel.newcastle_alarm
    name: Ring System
  - states:
      - arm_home
      - arm_away
    type: alarm-panel
    entity: alarm_control_panel.aarlo_location_home
    name: Arlo System

This is what is currently working in Core 2024.5.5 (I’ve reverted back since Core 2024.6.x broke these). These are working through the Ring MQTT and Arlo integrations.

That’s your card config not your alarm config.

I see you are using the RingMQTT add-on which uses discovery. So there will be no yaml config you can change.

However, according to this there is a new version of the add-on that fixes it. You just need to update.

Thank you. I did see the Ring MQTT update that fixes this issue. However I still have the issue on the Arlo side, and that integration hasn’t been changed yet so I don’t want to have one system working and one not working. I guess the best thing to do is just wait for the Arlo update before updating to the 2024.6.x core?

Seeing the same thing, using an mqtt alarm, and now it displays a huge keypad, how to disable it?

Speak to the developer of that integration.