Core_deconz missing API permission for /hardware/trigger

Hi all,
I am running core-2021.6.6 on Home Assistant OS 6.1 (on a pi4). I have a ConBee II with firmware 266b0700.

I have recently had an issue where none of my zigbee sensors were updating and found that deconz had not been working. After a full shutdown and restart of HA everything seemed to work okay for a number of days. But again today i noticed things again not working correctly. When i went in to deconz via the vnc plugin i noticed none of my devices had any connections between them. Then when i looked at the supervisor i see the following error messages every second.

21-06-28 19:36:26 ERROR (MainThread) [] Invalid token for access /hardware/trigger
21-06-28 19:36:27 WARNING (MainThread) [] core_deconz missing API permission for /hardware/trigger

Looking in the deconz ha documentation it mentions to check you have the latest firmware (which i have done) and the latest software. I have the latest available HA OS and core versions.

I have restarted the deconz docker container and performed a full shutdown and restart of the pi but still no luck.

I have not really debugged deconz in the past and not sure exactly where to start to resolve these errors. Has anyone seen these errors before?


I removed the deconz integration, restarted homeassistant. It discovered deconz again which i added which re-added the entities again. But none of them are reporting data still.

I still get those errors in the supervisor logs every second :frowning:

Any ideas of what else i can try?

So it turns out the auto update option for the deconz addon was not working. Even turned on it had not been updating. Manually updated then restarted homeassitant and those errors stopped.
Working through updating my sensors as they all changed names since i removed and added the integration, but other than that all seems to be working again.

1 Like

This also did the trick for me.
It did not automatically update too… I was on 6.3.0, now I am on 6.9.0 and no more Errors for now.
Thanks for the info!