Core update to 8.4 bricked my zwave JS

I updated the OS on my Pi4 to 8.4 Yesterday.
For some reason zwave JS doesn’t work anymore after that.
I could not find the isseu here and not in the buglist on GH.

. First I tried to upadate to HA 2022.7.7. No result.
. Then tried to go to a previous backup… But then I found out that the standard backups did not include the HA OS… :frowning:
. Now trying to go to a previous manualy made backup…

Does anyone else has this isseu or is it just me? :thinking:

. The previous manualy update was HA 2022.6.4 and this worked. Zwave JS was working again. (operating system = 8.4. apparantly this is not in the manually backup either…_
. Updated back to 2022.7.7 and the problem came back…

In the logs there was this massage:
2022-07-27 12:41:56 WARNING (MainThread) [homeassistant.config_entries] Config entry ‘Z-Wave JS’ for zwave_js integration not ready yet: Invalid server version: Z-Wave JS Server version is incompatible: 1.17.0 a version is required that supports at least api schema 20; Retrying in background
2022-07-27 12:42:36 WARNING (MainThread) [homeassistant.components.zwave_js] Device dc98f4cc16c13c27267ffcb4bd453491 config entry is not loaded

add-on Zwave JS is at 1.6.4 (latest)

To awnser your question, no problems here with the update.

If you’re looking for actual help, you might want to include log information and such.

1 Like

sometimes it helps to remove the zwave stick from usb for a second and put it back again :wink:

1 Like

I’m back at HA 2022.6.4 for again for now.
Zwave JS is running
(all other add-ons that I use are updated to latest.)

When I tried to update Zwave-JS to, the log file gave me this massage:
Logger: homeassistant.components.zwave_js
Source: components/zwave_js/
Integration: Z-Wave JS (documentation, issues)
First occurred: 13:53:32 (1 occurrences)
Last logged: 13:53:32
Failed to connect: Cannot connect to host core-zwave-js:3000 ssl:default [Connect call failed (‘’, 3000)]

So I returned to the above version as I want my switches to keep working…

I don’t know if this has anything to do with it but I found this in the 2022.7 announcements

When installed 2022.7.7 + Zwave-JS
I had the same problem.

This problem started for me with the update of OS 8.4 on teusday evening…
2022.7.7 was next to install, but it did not fix it…

But it could be something else…
Monday I tried to update firmware on one Zwave node. It took a long time to get to 73% after that I clict te screen away as it should finish in the background. (Or… it never did finish firmware version is still the same as before trying to update).
It could or could not be related…

A lot of devices need to be reset.
So: update firmware → exclude → factory reset → include again
Then they are running the new firmware.

thanks. I did not know that the divices needed a factory rest aswel.

I had the same issue. I suspected the 8.4 release, but the Z-Wave JS to MQTT 0.44.1 update was waiting at the same time. It wasn’t just ZWaveJS which had issues, but also to the DSMR device didn’t work anymore. Turns out that the USB devices were missing for both, but the Zigbee USB device was still present. I tried restarting, but that did not help. I eventually restored from a one day old backup and everything came back. But the os remained at 8.4, so it must have been the Z-Wave JS to MQTT update. I’m still at 0.44.0 at the moment, but will retry the 0.44.1 update soon.

Just to make sure:
This is just if the device’s FW has been upgraded and is not required for all devices after the OS upgrade to 8.4?

By the way, on my NUC (using HAOS Generic x86) I cannot even upgrade to OS 8.4:
I start the update, but after it’s done, I stll have 8.2. in place.
Is there a trick how to do this?

yes, only the updated device.

Thank you for the lightning fast response :slight_smile:

1 Like