Could not create snapshot

I can’t create a snapshot for new installation on RaspberryPi 4. It says “Creating a snapshot is not possible right now because the system is in startup state.” while system started long time ago. Any idea what could be wrong?

Home Assistant OS 5.12

I’m experiencing this same problem, though I’m now at a newer Supervisor:

Ubuntu 18.04.5 LTS

Turns out I haven’t had a successful nightly scheduled backup since March 3rd, and the hassio backup folder is empty!

WARNING (MainThread) [] ‘SnapshotManager.do_snapshot_full’ blocked from execution, system is not running - CoreState.STARTUP

1 Like

Had the same problem, restore or create snapshot would fail with the system is in startup state error.
Restart of the core solved it.

Fyi running core-2021.3.4

1 Like

I was having the same problem after updating to 2021.6.6. I decided to check Supervisor>System>Log Provider “Core”. There was a warning for the “Updater:” command (Configuration.yaml), that an optional command was deprecated (include_used_components: true).

The other error that I had was an integration for Plex, that I was not using and had not setup, so I deleted it.

I dealt with the errors, restarted and it then allowed me to take a snapshot.

I think snapshot may be prevented if there are errors in the Configuration.yaml or any of the other files and integrations. It might be an idea to check for errors. It was the first time that I had checked “Log Provider - Core”. It is usually defaulted to “Log Provider - Supervisor”. There should be a drop down to the right to change it to “Core”. I attached a snapshot just to show where to find the “Log Provider - Core”

Had the same problem can’t create snap shot

The only way I found to stop the error was a full restart ie power off then power on then I could do a backup

1 Like

Has anyone found a solution to this problem? I’m getting the same issue with HA OS running on Odroid N+:
Core: core-2021.8.8
Supervisor: supervisor-2021-06.08
Host OS 6.2

When trying to create snapshot I get following error:
Could not create snapshot. Creating a snapshot is not possible right now because the system is in startup state

The supervisor log has following entries, everything I try to create a snapshot:

21-08-22 14:48:29 INFO (MainThread) [supervisor.snapshots] Found 0 snapshot files
21-08-22 14:48:29 INFO (MainThread) [supervisor.snapshots] Found 0 snapshot files

No errors in the Core logs. Only one warning about having installed hacs.

I tried to reboot; tried to poweron/poweroff, etc. nothing helps.

Letting Home Assistant just sit for 24 hours seems to have solved the problem. Weird.

After 3 days with this issue and several reboot, I tried to power off system and wait for some minutes before restart.
This solved the issue and finally When HA restarted I could do backup again. Thanks myle