Could not resolve host

Hi,

I’ve the last installation of hass.io (0.63.2) with ssh and duckdns addons on raspberry pi3.

Recently, I noted a connection problem with external resource, I couldn’t resolve external host:

core-ssh:~# curl https://home-assistant.io
curl: (6) Could not resolve host: home-assistant.io

And in the logs panel of the duckdns addon screen:

starting version 3.2.2
# INFO: Using main config file /data/workdir/config
ERROR: Problem connecting to server (get for https://acme-v01.api.letsencrypt.org/directory; curl returned with 6)

It’s embarassing me cause I can’t push my configuration changes on GitHub like the following steps: https://home-assistant.io/docs/ecosystem/backup/backup_github/

Any idea what is wrong? For information, I can access to my installation from outside of my lan.

Thanks in advance.

If you use the Pi-Hole addon, you must setup a static IP on your host and your hassio box can’t use Pi-Hole as it’s DNS server.

I don’t have the Pi-Hole addon and I setup a static IP on my host.

The errors suggest you’ve got some sort of DNS issue. Verify your DNS settings are correct and your DNS server is working.

Did you setup the static ip editing the resin-sample file? Did you set the DNS server there too?
BTW, if you can it is easier to use DHCP reservations to give a predefined address to the RPi.

I setup de static ip from the resin-sample file, directly on the sd card. In the past, everything was ok.
Now, it’s strange cause I can do the update of the hass.io and the addons (from the frontend interface, hass.io menu) but I can’t reach any external ip from de ssh client and my duckdns doesn’t update the IP.

I will make the configuration change that you notice me. I’ll come back with more feedback.