Cover has position slider, but not cover does not set position state

Hi there!

I have a Zigbee smart blind switch, which shows up in Home Assistant as a cover. It has the following controls: Up, Stop, Down, Position:


The trouble I have is this switch has no concept of position, and the attribute is stuck at 100%. Because the position state is never set, it flicks straight back to 100% constantly and the “Up” button is thereby greyed out. It’s basically rendering the cover unusable.

The Zigbee device signature is:

  "node_descriptor": "NodeDescriptor(byte1=1, byte2=64, mac_capability_flags=142, manufacturer_code=4098, maximum_buffer_size=82, maximum_incoming_transfer_size=82, server_mask=11264, maximum_outgoing_transfer_size=82, descriptor_capability_field=0)",
  "endpoints": {
    "1": {
      "profile_id": 260,
      "device_type": "0x0202",
      "in_clusters": [
      "out_clusters": [
  "manufacturer": "Feibit Co.Ltd",
  "model": "FB56+CUR17SB2.2",
  "class": "zigpy.device.Device"

Is there any way to set the position from another sensor (which would be hard) or better yet just disable the position attribute?

Many thanks!