Cover.mqtt and tilt_status_template help - SOLVED

I have build some blinds are based on tasmota and respond to the mqtt topics for their position. Only the tilt of the blinds is automated at the moment.

I am using a mqtt cover defined line this.

  - platform: mqtt
    name: blinds
    tilt_command_topic: 'cmnd/blinds01/PWM1'
    tilt_status_topic: 'tele/blinds01/STATE'
    tilt_status_template: '{{ value_json["PWM"]["PWM1"] }}'
    tilt_max: 57
    tilt_min: 155
    tilt_closed_value: 57
    tilt_opened_value: 155

The min and max values are correct and they work nicely.

Here is the correct state status JSON

2020-01-09 18:32:39 DEBUG (MainThread) [homeassistant.components.mqtt] Received message on tele/blinds01/STATE: b'{"Time":"2020-01-10T00:32:38","Uptime":"0T01:57:07","UptimeSec":7027,"Heap":26,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":24,"MqttCount":1,"PWM":{"PWM1":155},"Wifi":{"AP":1,"SSId":"gaul-hw","BSSId":"92:2A:A8:1A:31:3D","Channel":11,"RSSI":100,"Signal":-46,"LinkCount":1,"Downtime":"0T00:00:11"}}'

But I am not able to see tilt state updates. the tilt status isn’t being updated from tilt_status_template. However if I use the slider on lovelace UI to update the blinds they work. I need this because I have some node red base automations that varies the blinds positions depending on how bight it is (reading in LDR value)

Is this a bug there the tilt_status_template isn’t being read? or used?

That worked the problem with updating the state is the tilt_min settings cannot be bigger than the ‘tilt_max’ . Now the with the correct min and max, I dont need the inverted true setting either…