Cover Somfy IO Overkiz


I currently have several roller shutters controlled by Somfy IO remote controls and integrated into home assistant with Overkiz integration, the link of which you will find below.


I can control the roller shutters with an open/close button or by defining an opening percentage value. Except that the position displayed is always -24%.

Furthermore, the integration includes a sensor called target closure which displays the shutter closing percentage (sensor.chambre_1_target_closure) correctly.

Wanting to display the opening percentage of the shutter, I created a sensor to invert the values ​​named (sensor.percentage_ouverture_chambre_1).

I would now like to integrate the opening values ​​of the sensor (sensor.percentage_ouverture_chambre_1) with the rolling shutter (cover.chambre_1).

Currently the attributes of cover.chambre_1 from the development tools are:

current_position: -24
device_class: shutter
friendly_name: Chambre 1
supported_features: 15

Thanks for your help.

What is the Somfy gateway you are using?
I have a Tahoma Switch but I know that some people are using other pieces of hardware.

I use the tahoma switch too

Can you compare with my version, because the percentage is correct in my case (for all my 9 covers) especially the microfirmware version.

This is one of them:

And the Tahoma Switch


Because I don’t have the target_closure sensor.

Anyway, I did a card with my covers, including values from other sensors, here is an exemple


The micrologiciel of the tahoma switch its the same.

But its not the same on the component IO.

If i open the default view for control my cover, it always shows me an aperture value of -24%.

The target closure component it never use but it represent the percentage of closure except when it’s totally open it show “unknown”.

I created a new sensors to correct this problem with this code

- sensor:
   - name: "Pourcentage ouverture salon jardin"
     unit_of_measurement: "%"
     state : "{% if is_state('sensor.salon_cote_jardin_target_closure', 'unknown') -%} {{ 100 - 0 }} {%- else -%} {{ 100 - states('sensor.salon_cote_jardin_target_closure') | float }} {%- endif %}"

but I don’t know how to integrate the sensors into my roller shutter.


What do you mean by “integrating” ?
Because it will not be possible to add an attribute to the published cover sensor by overkiz.
At most you can create a cover template based on your value and the existing cover services (by overkiz) following this:

  - platform: template
        device_class: blind

Read the provided link for options, like icon, state, …