Crashing logs?

Hi all. I am having consistent crashing from my system. I am using a raspberry pi 3b plus and I am wondering if there is a way to check and see what is causing the crashes I don’t see anything from before the restart in my logs. I apologize if this has been posted, I am on mobile and it does not show me the related topics

The logs get wiped at restart.

Make sure you have SSH setup then try to SSH into the RPi after a crash. If lucky you will still be able to SSH in and then you can view the logs prior to restarting it.

Your real logs (the system journal) aren’t wiped at restart. Here’s how you get to them

1 Like

Thank you. I tried to follow the instructions to access on root. I am used to running supervised but switched over recently to the image for balena etcher so that I’d be “supported”. I’m doing something incorrectly when creating the authorized_keys file. I’m still being asked for username on port 22222 and being denied access. I also attempted the recommended way, but I am still kinda new to understanding how to navigate via a terminal or command prompt. I have figured out cd but not much else, so I was able to find the folder, and if I’m not mistaken ls lists any files in the folder, but I don’t know how to copy the file or folder out to be able to use journalctl, and don’t have the slightest clue what it means when it says to another system… do I need another pi to make this work? Stupid idea, can I copy the backup to the installation with supervisor and ssh in to just use the journalctl that should be in Raspbian?
I was getting the error showing that it was having unclean shutdowns, so I deleted the db file, I am hoping that it stays running now, but I swore I did that last night.

I was actually trying to follow that but got a little confused.

Would this warning have anything to do with it? I have no clue what it means and just found it.

Logger: libav.hls
Source: components/stream/
First occurred: 8:29:59 PM (7 occurrences)
Last logged: 9:01:07 PM

DTS 133781490 < 133784280 out of order
DTS 141340860 < 141354270 out of order
DTS 145663020 < 145672740 out of order
DTS 181030950 < 181031580 out of order
DTS 182651670 < 182662740 out of order

Supervised is still “supported” as long as you use Debian as the underlying OS.

If you are now on HA OS then you need to SSH in on port 22.

Also, you can simply connect a monitor and keyboard and access the CLI directly.

I can port in fine on port 22. The issue is that afterwards I get a little lost. I know how to navigate, but I don’t know how to copy folders to other locations, and I wasn’t sure where to copy it as per the instructions in the other post. Not sure what it was referring to with “another system” if it was meaning another system within the pi, kinda like containers in Docker, or if I had to be able to move it to another Linux based system externally, which if that’s the case, I do not have at the moment, put Ubuntu on Switch briefly, but if didn’t do what I needed (missing libraries unavailable for Switch) so I removed it.

Port 22222 is the backup method they had mentioned, I got lost on auth keys there.

At this point I feel like it may just be easier to do a fresh install when my new SD gets here today and to copy paste each file from my config folder in there separately.

Debian is supported? I was under the impression that Raspbian was a form of Debian? I guess I was wrong. At least this means I can go back to a set up that I am used to.

Raspbian and Ubuntu are both derivatives of Debian but they aren’t supported. As the ADR says:

Debian Linux Debian 11 aka Bullseye (no derivatives)

Supervisor is deeply intertwined with the host system. It may run as a container but it isn’t host independent at all. Derivatives like Ubuntu and Raspbian change many things about debian that supervisor depends on so it won’t work there.

To access the logs use the commands here:

You don’t need to do any copying etc.

Wait, are those not the logs that delete when it restarts? It doesn’t just crash, it reboots completely, so it starts up again on its own. Happening every hour and 4 minutes it seems.

Do you have a good walkthrough for proper debian installation? I tried to flash the latest debian bullseye by using Balena Etcher, but it is asking me for a username and pw. When I try to follow the directions on the “official” (not sure how official it really is) site, I get stuck. It says to find the name of your SD card, then gives instructions on how to do that, I’m trying to install to the sd card via windows and when I follow the terminal directions it tells me no such diirectory.


Ok, you didn’t mention this originally…

Follow the official HA docs (which link to here)

Or, there is a community guide here.

I believe the community guide is exactly what I needed. TY!

1 Like

Well, this is getting frustrating. I am following the instructions. I insert the usb into the pi, connect keyboard, ethernet, hdmi, turn it on, press f12 and tried DEL, nothing ever shows up on screen.

Edit: another question… Will this cause issues when it comes time for the Matter demo? I want to participate in that after work that day.

Edit 2: Yeah, kinda irked. Someone on stackoverflow said “there is no default”… yeah, there is. I installed properly the first time. The username is “root” and it takes you right in. All I needed to do was download the image from Debian and write it with either Balena or Pi Imager, then type “root”.
Installing supervisor now. Thank you for the insight.

I’m losing my mind. I keep getting on a path that seems to be working and then I hit a bunch of dumb crap. I am pretty much over everything at this point. Can someone please tell me how the heck to boot from USB on the pi once I’ve made the boot drive? I can’t figure out if I need a blank card in, if I need a card with something specific in. I am to the point of this is physically hurting my brain. PLEASE. There is a huge disconnect in the guide. It acts like all you have to do is turn it on and hit F12 or DEL. I have to say, that step is MADDENING… like do they know what they are saying to do? Because “something like” isn’t very accurate… what do I press? I’ve tried both. I am starting to believe this guide isn’t for Pi. The agent isn’t available as a debian distribution for arm64 and thats the only debian ive been able to load today. I can’t for the life of me remember how I did it before.

Haven’t done that before so not sure what you’re facing but might help to link the guide. That way people that have can comment on it and direct to a different one if necessary

It’s the one Sparky posted

Or just step by step on how to properly install debian. The comm guide linked is the only thing that touches installing debian in anything I’ve found anywhere on the net.

Oh ok. I think I got thrown by the USB boot, thought you were doing something different. I assume you’re trying to boot from a USB SSD or something? Perhaps try getting it working while booting from microsd then doing that? There’s actually a “move datadisk” option in the UI you could try once ha is running, I think with that HA will do the work for you.