Created Group successfully, now won't display

UPDATED: I decided to just delete the original Kitchen light group and recreate it. That solved the problem although I don’t know why it wouldn’t display after it successfully displayed fine, but for the moment, I’ve fixed the problem by deleting and recreating. Thanks

I have 4 unique insteon switches in my kitchen. They’re all successfully setup in HA. I created a group to include all 4 and that worked great. Now it’s not showing up on my dashboard. So I was going to recreate it, but when I start to create the group again, I can see the kitchen group is still there. It’s just not displaying on the dashboard. I have a bedroom grouping that I also created and it’s working and displaying in the dashboard perfectly. How could the kitchen group still be created, but not showing up. Note: It is not “hidden”. I’ve triple checked that it shows enabled. I’ve also restarted the instance a few times but it still won’t show up. any help would be appreciated. Thanks