Creating a snapshot is not possible right now because the system is in freeze state

Sorry for late response. I think you figured it out, but it will let you restore to previous snapshots after restarting Home Assistant.

Same issue in core-2021.3.3

Same issue here on my 2021.3.3

I am having the same issue. Was able to upgrade to 2021.3.4 but will not create or restore backups due to ‘‘freeze state’’. I have restarted Home Assistant but problem persists. Any further ideas on a solution?

Same problem too. Restarted the host and still same message.

1 Like

Same here. 2021.3.4 -> Creating a snapshot is not possible right now because the system is in freeze state.

core-2021.3.4 It turned out to me that the message is completely correct. When a snapshot is taken, the system appears to be frozen for the duration of the snapshot’s creation. Which also makes sense. Depending on what kind of snapshot you create - partial or full - and depending on how extensive the configuration of the HomeAssistant instance is, it can possibly take a long time until the snapshot is created. In my case, for example, a full snapshot is now 5 GB in size and it takes several hours for the snapshot to be displayed under “available snapshots”. During this time I also get the message “system is in freeze state”. As soon as the snapshot is ready, the message has disappeared and I could take a new snapshot.

So just leave it? How would I know if it’s still working on creating the snapshot? 5Gb is big. So this is by design? I’m still on core-2021.2.3 and I’m not upgrading until I know this is fixed.

Maybe the supervisor system log will help you.

In my example you can see that add-on core-mariadb is not finished at the moment.

Just came here because of the same problem… it seems that during a restore or a snapshot the system is frozen.
Seems only logical to me this way, but the lack of UI feedback (lucky I checked the logs) make it look like a bug or something.
So, snapshot/restore recently = system frozen to protect messing the files.

I have faced the same message and I understand the reasons.
I would be nice though to create a message that “Snapshot is in progress” so it is clear without looking in forum and logs… :slight_smile:

2 Likes

Having the same issue for a few weeks now.
Backup does not actually fail however… it does happen in the background (can bee seen that it is working because CPU is working quite hard (even after this failure message). and in the end after a few hours of it working in the background snapshot will appear and will be downloadable
image
in the beginning i thought it was because of my InfluxDB that was huge. I deleted InfluxDB because it had a lot of unnecessary data anyways and recreated a new empty one with just a few includes (instead of including everything) But still i am getting this error message when backing up
Also when checking the home-assitant.log i have those two lines only

And when checking the Supervisor logs everything looks OK. the error message happens when actually doing the backup for mariadb. dont know if it is related. FYI maria db has only a retention of 7 days so this DB is not that huge

1 Like

I’m adding to this conversation although the reason shown for not being able to create a snapshot is due to “system is in startup state”.

Today I noticed that there was a Core update available, core-2021.3.4 -> core-2021.4.3. I went to create a snapshot before updating and am seeing the same msg Creating a snapshot is not possible right now because the system is in startup state..

I’ve read through the other posts here and I find zero reasons or resolutions. I don’t want or mean to be negative, truely, but dam?t, every time I turn around something borks with HA. While I love the concept, I keep running into issues that require too much fing time to dig into and not find any solution, like this one. I had made no changes to my system. All I want to do is update and move on with my day. I don’t want to spend the rest of my day with what should not be an issue.

Actions:

  • Restart core - didn’t resolve
  • Reload Supervisor - didn’t resolve
  • Restart Supervisor - didn’t resolve
  • Restart Host - didn’t resolve

Every time I click Create snapshot, the log is appended with ‘Found 1 snapshot files’. There is no other information in the log to indicate the reason/cause:

21-04-10 18:09:55 INFO (MainThread) [supervisor.snapshots] Found 1 snapshot files
21-04-10 18:10:21 INFO (MainThread) [supervisor.snapshots] Found 1 snapshot files
21-04-10 18:11:39 INFO (MainThread) [supervisor.snapshots] Found 1 snapshot files
21-04-10 18:15:25 INFO (MainThread) [supervisor.snapshots] Found 1 snapshot files
21-04-10 18:24:03 INFO (MainThread) [supervisor.snapshots] Found 1 snapshot files
21-04-10 18:26:45 INFO (MainThread) [supervisor.snapshots] Found 1 snapshot files
21-04-10 18:26:54 INFO (MainThread) [supervisor.snapshots] Found 1 snapshot files

Respectfully,

Install:
hassio-supervisor running on Debian 10

Given that I’ve read a number of posts related to this issue w/ zero resolution, and wanting to move forward, I wanted to see if an upgrade would solve the problem. It did. Although as a software dev myself, it shouldn’t have. That being, what broke it in the first place where it worked with core-2021.3.4 and then arbitrarily stopped working?

Going to the Supervisor -> Snapshot tab and choosing Create continues to fail throwing the error msg. So I made a backup of the entire hassio-supervisor directory and proceeded to do an upgrade from core-2021.3.4 -> core-2021.4.3. I was prompted to create a snapshot before the upgrade. To my surprise, Instead of seeing the message that a snapshot can’t be created because the system is in startup state, a snapshot was created and the upgrade was successful (in that it didn’t error or crash, further testing before I sign off on the upgrade). It appears to me to clearly be an internal code issue where the system gets stuck in whatever state it thinks it’s in and thereby fails to be able to create a snapshot manually.

Best

Now i’m getting the same. Cannot restore anything. In the middle of a migration!!

Got it working now - just very slow at restoring each addon. 1 by 1.

The above messages indicate that “Freeze State” means one of the following is true:

  • A Snapshot is in Progress
  • A Restore is in Progress

So, you cannot do another restore, or another snapshot, while one is running.

5 Likes

I just posted a response on another similar topic, but the forum doesn’t allow similar posts, so I will link it below. The solution that worked for me was to fix an error for deprecated code that does not show up on default logs. The other error that I had was an integration for Plex, that I was not using and had not setup, so I deleted it.

https://community.home-assistant.io/t/could-not-create-snapshot/287862/5?u=rorschach-x

Same here. I am on core-2021.6.6. Either manually snapshot or auto does not work. Was able to delete some of the older snapshots, but that did not solve the issue.

Can confirm. Had same issue tired to make snapshot multiple times with restarting and debugging issues from log, but after 2 h with total size of snapshot 5,5 GB there is snapshot created. It seems stuck because it says that system is freeze and log in supervisor is continuing to give new entries beside those about snapshot.
So another solution to this could be patience.

Same with 2021.9.7.