Creating a Z-Wave Group (Association?) within Home Assistant?

As the Z-Wave panel for HASS is still under heavy development I would recommend you to set the association using OpenZWave Control Panel (OZWCP).

In order to do this you need to stop HASS and then manually start OZWCP from the relevant folder using ./ozwcp -p 9999 or any other port you find suitable. Let OZWCP run through the regular node query, set the association with the correct group, verify the result and close down OZWCP.

Thanks @fuse, I’ve actually tried this before and still wasn’t able to figure out how to make this association through OZWCP. Google didn’t turn up much help either, would it be possible to point me in the right direction for any documentation on this?


Unfortunately I’m not able to give you the correct instructions right now, so you’ll have to do with the somewhat vague steps I can come up with below.

  1. Stop the HASS service.
  2. Start OZWCP and initialize the controller.
  3. Wait for the node query to finish.
  4. Under “Controller options”, choose “Set Association”.
  5. A new section will show up right below.
  6. First you choose the device you want to receive the association. The list is presented with the node IDs only, followd by the association group. A dot (.) separates the ID from the group number.
  7. Highlight the device that is to be controlled in the field on the right.
  8. Send the association.

As I mentioned above the steps are not precise. A couple of the steps might even be wrong since the instructions are written based on what I can remember from the previous association I set a long time ago.

Hey thanks! I appreciate this. Unfortuntely I didn’t have the “Set Association” command under Controller options. Am I looking in the right place?.

Looks like this feature is still under development. Would love to add myself to the list of interested parties on this one. Seems like the final requirement for me to ditch OZWCP.

I was able to do this entirely within hass, no OZWCP needed on version .49.

  1. Under “Z-Wave” > “Z-Wave Node Management”, select the node that will be sending the command from the drop-down.
  2. Under “Node group associations”, select the receiving node under “node to control”
  3. Then select a group (“group 1” works for me).
  4. Finally, click on “add to group” and it should make the association.


Thanks for this!
Maybe my issue is that I don’t have any groups in my network? Was Group 1 already in there for you? Anyone know how I would go about populating those groups? That might be my issue.


That was already in my list on my system.

I’m interested in this too. I dont have the option for any groups. Will have to mess with OZCP later this week I guess.

I have a 4 Button Aeotec ZW130 Device and HA Version 0.50.1
I’d like to add Button 1-4 to specific groups.
I tried the group association like described here. But my device is not showing up the button value in HA.

ZW130 Aeotec Device:

I have the same device. Does anyone have instructions on setting it up with Home Assistant?

I think I figured it out. You can use scenes. You can even add it via the ZWave config in Home Assistant.

Here is the automation configuration.

  • alias: Wall Switch Button #1
    platform: event
    event_type: zwave.scene_activated
    entity_id: zwave.wallmote01
    scene_id: 1

    • service: notify.slack
      title: “Button #1
      message: ‘Test button #1
  • alias: Wall Switch Button #2
    platform: event
    event_type: zwave.scene_activated
    entity_id: zwave.wallmote01
    scene_id: 2

    • service: notify.slack
      title: “Button #2
      message: ‘Test button #2

Did even better now. I managed to get the groups working.

  1. Stop HA
  2. remove zwcfg_* files
  3. restart HA
  4. let HA rebuild zwcfg_* file
  5. restart HA
  6. Now ZWave Configuration in HA shows the Aeotec Wallmote with groups

Just curious if you had any problems with deleting the zwcfg file? When I had some z wave issues a long time ago, I tried something similar and that caused all sorts of issues for me. That was probably in the 0.4x version range though.

Did this problem ever get a resolution?

I am also having problem getting Node Group Associations to work.

Clicking on the drop down list doesn’t seem to do anything.

Using 0.101

The drop down not working is a separate issue, should be fixed next releases.

1 Like

Is this likely coming soon (next few weeks or month), or would it be advisable for me to drop back to an earlier version?

Very soon I would think.

1 Like

I don’t know if this is a issue or not but the device must support associations before the feature is exposed/available I have been able to create associations for some time withing HA (not Check the manual for your device.

From my understanding, the groups are part of the device. For my devices, group 2 is for on/off control, and group 4 is for dimming control.