Current State Node: no For option when using >

Hi, I have a smart power plug with integrated power metering to monitor my washing machine.

I never turn on/off the power of the plug (always on) an control the washing machine itself. To detect that a washing program is running I want to set the Current State Node that the power is > 5 W for 5 minutes to trigger a notification. However, if I choose > at If State, the For option to set amount of minutes is removed. The For is only available when If State is set as “is”.

Seems the current state node cannot do what I want out of the box right? What would be a good alternative way?

Events: state node?


Hm yes indeed, seems what I’m looking for. Guess I could use some more sleep.