Custom cards not working in Lovelace after upgrade to 0.81.0


I upgraded to 0.81.0 with the result that several of my cards stopped working.

I get the following error:
Undefined is not an object (evaluating ‘hass-states’)

I noticed that id:s are now automatically added to my ui.

On the home view I have there vertical stacks.

In stack one nothing is shown (red error message)
The stack includes the following cards.:

  • custom:mini-media-player (4)

In stack two nothing is shown (red error message)
The stack includes the following cards:

  • entity-filter
  • glance
  • entity-filter
  • entities
  • custom: weather-card
  • entities

In stack three the cards are shown but one card is not shown correctly:

The stack includes the following cards:

  • entities (In the list of entities some are type: custom:fold-entity-row that are not shown correctly)
  • entities

It seems that the custom cards are the problem. If the stack includes a custom card is does not work. The case of fold-entity-row is special as it is not a card in itself but a special way of defining an entity in an entities card.

I verified this by removing the custom:weather-card from the second stack and everything else appeared.

Interestingly some custom cards still work:

  • custom:button-card
  • custom: slideshow-card
  • custom: tracker-card

Any input on these problems?

I get similar issue with:

  1. custom cards
  2. !secret (already reported in another thread and on github)

hass is undefined

Ok - I have a problem with Google Maps Travel Time. This may be due to the api being in my secrets.yaml file. I also raised this as an issue.

I moved my custom:weather-card out of the vertical stack and al of a sudden it worked. So the issue seems to be with custom cards in a vertical stack.

Definitely a problem with vertical stack. I have tested the other custom cards and they also work outside of a vertical stack.

both stacks: horizontal & vertical.

according to discord discussion the issue is known and being fixed

Perfect - I will just wait.

i am seeing all custom cards stop working. i’ve tried 0.81.0 and also tried 0.84 and the latest 0.85.

i see that the team is pushing for lovelace to be the default UI (which i agree) and are allowing for in browser editing(still a little painful but pretty good overall).

I did the process to migrate my ui-lovelace.yaml into the raw config editor, but where you would normally include a resources section in lovelace yaml, if i add that in the raw config editor and click save, i get no errors, but i still see the error of not detecting the custom cards when exiting out of the editor.

so, then if i go back into the editor, i see the resources section is missing again. anyone else experiencing this?

It should work in 0.85.1.

Make sure you empty caches and all site data. Only emptying caches was not enough for me.