[Custom component] AsusRouter integration

Ah, thanks so much!

Well, I did the “redownload” thing, but then got an error message “You are running Home Assistant version '2022.11.5', but this repository requires minimum version '2023.1.0' to be installed.
Well, that explains it! I will wait a few more days, until things around the new 2023.1 release have settled.

My thoughts 2, but the latest 2-3 updates, i had to “Redownload” after reading about an update here … and my HACS and HA have been rebooted and restarted several times

Weird. Did not ever happen to me - all the HACS updates are shown when available

Well i don’t say im an impatience person, but eventually i guess they “turn up” here also, also happens( sometimes some delays in this end) with the officiell HA updates … and lately( last 2-3 weeks) i’ve been sitting and my laptop every day, so i’ve seen the release “note” in here … and i guess i just didn’t have patience enough, so i just clicked Redownload :slight_smile:

:loudspeaker: Support the feature request to add AsusRouter as HA Core integration

Hey. I would like to remind you about the possibility to vote for the feature request

1 Like

Hi. I’m using two asus-routers as meshnodes only. Will i be able to use devicetracking? And would I need to add both the nodes in HA?

I tried only adding my main node, as a mesh-node. And then I only get sensors from the router, not any devices(as far as I can see)


I changed it to router mode and i got all the devices.


If you are using Asus AiMesh, you cannot have only nodes - there should be 1 router - the one to which your internet is actually connected. Add that one in the router mode in configuration to get the most reliable device tracking. No need to add all the nodes.

If you are using any other kind of mesh, you can try adding one of the nodes in router mode, but I am not sure, whether this will be reliable tracking

I’m pretty sure you can set it as Access Point mode, so none of the nodes will be acting like a router…

Something like this (not tested):

As @EdwardTFN said, you can have it as a access point only.

I use a Palo Alto Firewall as the “router”, then one Asus as AP and one Asus as Mesh Node.

But it worked with configuring one as Router and one as Node.
Only “issue” is that I get alot more entities than needed(like disable firewall, parent control etc).

I see. Actually, this is the mode, about which I did not think a lot yet. I will try to find a solution for AP mode, so I will have all the useful sensors, but won’t have useless

1 Like

As always; keep up the great work, @Vaskivskyi !

On a side note: has there been any progress with the bandwidth monitor, for each client?

Hey, not yet, but it is waiting for its turn. Soonish :slightly_smiling_face:

Currently, the work is mainly focused on making the backend library (and as a result the integration) more stable and less resource-consuming. There are a couple of places to optimize, which should help users with a bit older or a bit cheaper devices.

So there is a chance that the next AsusRouter version will not have lots of features in the release log, but will improve user experience of using the integration


Just want to add a “thank you” for looking into the AP mode. I came here looking for just this add-on and what it could do. I run my unit in AP mode with 4 AiMesh nodes. My primary firewall/router is OpnSense.

It used to do this, but now this integration doesn’t report the home assistant server itself in the list of connected devices. Am i missing a config parameter please?

Hey, no, this is not a feature of AsusRouter. All the devices connected and defined by the router as connected should be shown in the list. Is your HA server visible as connected in the router Web UI?

What type of connection is your HA server using? Is it directly to the router you integrate or through AiMesh?

Thanks. It does show up in the router web interface, in the list of devices connected. It is a VM running on a machine that also shows up on the list, but it has its own IP address. It’s very strange.

That should not be a problem, in principle.

I don’t have lots of statistics, but my 2 HA instances are actually working in exactly the same way in Hyper-V VMs of a PC and all 3 show up. But from time to time one of them might disappear for some period of time. I’ll try to watch their behaviour to find if there is something I can improve in tracking them

Thank you. Taking a guess here, the MAC address of the HA VM starts with 00. None of the other devices do. The HA VM is the only one that doesn’t show in the list in the integration. Maybe the leading 00 is a cause?

No, it should not be a problem