Custom Component: Crow Runner / Arrowhead AAP 8/16 Alarm IP Module

I’ve already received the UART-TTL it has the same chip the D-LINK cable has, and I used the pinout @jokkydee kindly indicated, but still no luck…

The software makes TX blink on screen and on the UART but…no RX activity…no connection…

Checked the interface with a multimeter and GND is pin 11 the rest of it I can not tell…

Hi @zarkov welcome! glad you found us :slight_smile: and hope you can find the help you need. A few things to note based on my past experience;

Firstly, the pinout on the IP module has the TX/RX pair swapped with respect to the Runner panel - I’ll talk about this further below. This may be what is wrong if you are using the same pinout as the IP module. The serial connector on the IP-module is designed to be connected to the Alarm panel using a crossover ribbon cable (only the TX/RX pair is crossed over).

Also worth checking which version of the Upload/Download application are you using. I have tried myself and was never able to successfully communicate with the Runner 8/16 panel via the serial interface using my TTL-USB adapter. However, I think this may have been because I was using the wrong version. I think if you search this thread you may find us talking about this to make sure you have the right version. My memory is a little faded on this, but I don’t think I tried using the TTL-USB adapter once I had the correct version, because I went straight to using what was much more useful for me - which is connecting a ribbon cable between the IP module and the Runner panel, and then using the Upload/Download tool over the TCP/IP connection. The beauty of this, is that whenever I want to change settings, I don’t have to get up on a ladder with a laptop and connect to the alarm panel, I just connect to it remotely on my PC already connected to the network. If you plan on using the Upload/Download application for the purpose of backing up and changing settings, this may be a very good reason to get the IP module - since you asked about that vs. getting the Wemos module.

On the serial pinout interface. In my setup, I have a ribbon cable going between the IP-module and the Runner serial interface - the outer pairs of pins on the Runner connector are not used (you’ll see I posted a photo of the connecter I had to sand down, to make it fit). It’s important to note that I needed a crossover between the TX/RX pair between the two boards - so a simple straight through ribbon cable could not be used - I actually crimped my own. So if you are trying to talk to the alarm panel, you’ll need to swap the TX and RX pair. I don’t think this will have fried your panel if you got this wrong, so I wouldn’t worry about that just yet.

Lastly regarding GND pins, as long as one GND pin is connected, that is fine - because all GND pins are shorted together on the PCB anyway. They would have probably just grounded all the spare pins - so there mostly likely isn’t any need to have that many and no point going to the trouble of connecting all of them.

Hope that is helpful, and let me know if you have any further questions. Goodluck

Hello @jokkydee!

Thanks a lot for your time and effort on your reply!

About the pinout I must say that first I tested all the pins with a multimeter, and on my panel I have, only one GND pin, with 0 volts, one pin with 13 V and all the rest measured 5 volts. So initially I put my UART working on 5 volts… no luck! Changed it to 3,3 V … no luck! Considering that…I even tried reversing the TX with the RX on the pinout, but no luck either! (with 5 V and 3,3 V)

As you said I could have a software version problem, but honestly I doubt it, I’m using the same version that I saw on a youtube video of someone that was configuring a panel like mine with the D-LINK cable and the software Runner (https://www.youtube.com/watch?v=YBVjSBuL5lk).

One thing that caught my attention on the video was the fact that software Runner has a CD led (maybe a representation for the presence of an extra needed CARRIER DETECT pin on the interface) always lit on the Window screen…

Could there be any problem on the COM port configurations selected on the Windows operating system?

Bits per second: 9600

Data bits: 8

Parity: None

Stop bits: 1

Flow Control: Hardware

Anyway, I even tried changing the Bits per second (9600, 19200, 38400, 115200), the Flow control (None, Hardware) but no connection was established…

Are there any specific configurations I should use for the UART CP201X that I bought on Windows (by the way I’m using Windows 11)? Or the default options, as shown above, are the correct choice? (specially about FLOW CONTROL which one must be the option selected?)

Here is a screenshot of the software I’m using (I always do “Run as Administrator” when starting the software as the youtube video mentioned):

One thing that seemed strange to me, is that whatever option I change on the COM port setting on Windows, the information that I coloured GREEN on the screenshot above never changes… it does not indicate anything about FLOW CONTROL, but…are those the supposed right options for the port configuration settings? I guess so…but…maybe not…

The software version is wrong? I don’t know…but for a Crow Runner 8/16 panel I did not find another version to download on the Internet…

Suggestions? Any? I really appreciate…

Thanks in advance!

You shouldn’t need to worry about the COM port settings in windows, because whatever application uses the COM, it can take control of the driver and use whatever settings it wants. For example, you’ll notice when using serial terminal applications like Putty or TeraTerm, you can change settings within the application, and it doesn’t matter what is configured by Windows.

Regarding the version, this is the version that I have and the only one which has worked for me:

image

Note that this version is actually listed as being for the Elite series alarm panels from AAP, not the Runner 8/16. I was confused at first because it seemed like the wrong version, but actually this is the only version that worked for me and the one you want. If you have a look through this thread I think you might find more information about it - I think you can still download it from AAP, but can’t be sure as it’s been a while since I last checked.

Thanks again @jokkydee!

I removed the software I had and installed exactly the same version you have, tested again, but still no luck…reversed RX and TX…changed the voltage on the UART to 3,3V and 5V but nothing happens…

The TX led on the software blinks at the same time the UART physical led also blinks, but no RX signal…

I guess there’s nothing more I can do…

Thanks a lot anyway for your patience and your time…

You should not use 5v on the fdti. You may have fried something in the alarm module.

In my case i was able to flash the ip module with the correct firmware required for home assistant. But a few seconds or minute after the reset it stops responding.

No http or ping.

If i am fast enought I can open the webpage or arm using telnet, this means all is working untill it stops responding. No http, no ping, no telnet.

Any idea?

Thanks for your answer, but I’m pretty sure that I haven´t fried my panel because I measured all the pins with a multimeter, before connecting the UART, in terms of resistance against ground and against the VCC pin of a IC nearby the fitting. And I also measured voltage on each pin with the panel turned on.

Until now no values have changed on my multimeter measures, before and after all the tries I’ve made, so I think no harm has been done to my panel.

In my mind, I’m starting to figure that some more pin has to be connected so the software CD led (carrier detect) turns on. It’s just a guess…

This sounds very similar to a problem I was having on my network, which has been discussed earlier in this thread. Same symptoms as you. It appears that the IP module can be fussy about what it’s sharing the network with, and may become upset by too many broadcast packets being sent across the network by other devices. My solution was to put the IP module on it’s own VLAN so that only Home Assistant could talk to it. Never had any issue after that and it’s been running for well over a year now.

You could be right about the carrier detect pin being necessary. I can say, I tried my best to do what you were doing and talk to the alarm panel via my USB-TTL adapter and I was never able to do it. So if you do get it working, you’ve done better than me. For me though, using the IP module to do the talking to alarm panel ended up being more desirable than via the serial port with PC, so that’s when I stopped trying with the USB-TTL adapter.