[Custom Component] extended_openai_conversation: Let's control entities via ChatGPT

Gotcha! In that case I recommend making sure gpt-4o is set as the model you’re using in config. I also noticed in previous testing that enabling the “Attach username to message” option immediately surpassed the token limit, but I just disabled it and never looked into that further. On top of changing the default model you should also make sure your exposed entities list in the voice assistant config doesn’t have items you don’t need.

1 Like

Is the integration tracks the chat history even after Home Assistant restart? I can’t figure…