Custom_components on Home Assistant Operating System

Where do I need to copy a custom_components\component folder on a Home Assistant OS instance for it to be recognised?

I have previously been running Home Assistant in Docker on a Synology NAS - Docker on the NAS stopped working so I’m trying a fresh Home Assistant Operating System install on a NUC as per Generic x86-64 - Home Assistant

On the old instance I ran this custom component:

Tried to install for this component by copying to \config\custom_components\amberelectric (the config folder where configuration.yaml is saved) as working in my old setup

Restarted Home Assistant and even the HAOS, then modified configuration.yaml - however when I then try to restart HA I get this:

Failed to call service homeassistant/restart. The system cannot restart because the configuration is not valid: Platform error sensor.amberelectric - Integration ‘amberelectric’ not found.

Do custom_components need to go somewhere else for HAOS?


That directory is correct. Did you run the same version of HA on your NAS or an older version. The reason your custom component does not load can be because it does not contain a version tag (but that could only show if your old HA instance runs an older version)

Thanks for that - yes I believe it was an older version running in Docker on the NAS, will try to get it back up and running so I can compare for sure

You will also need to add the the directory, restart HA, then add to configuration.yaml, then restart HA again. If you do both at once, HA will refuse to restart because the config check will fail.