Custom Dark Sky Animated Weather Card


#829

Is there a way to add the daily expected accumulation (sensor.dark_sky_precip_accumulation) under each day similar to how the chance of precip is listed?


#830

Please use github for feature requests:


#831

Hi !
I got this card working about one week ago, but I have noticed that the card is not updating automatically when the sensors values got refreshed from darksky website. I need to do a manual refresh of my HomeAssistant page to display newer values. It’s not convenient since I want to build a display mounted on a wall.
Any help will be greatly appreciated !
Mat


#832

The latest version has dynamic updating.


#833

Wow ! so fast ! Thank you, I’ll take a look at it.


#834

Is it possible to hide the text on the button?

image


#835

Remove this line:

entity_daily_summary: sensor.dark_sky_daily_summary

#836

Thanks for your response on that


#837

I tried the new version, but it does not work.
It even seems to break the global dynamic refresh. For instance, with the latest version, my lights will not show properly their ON/OFF state : I need to manually refresh the page for that. But it works again perfectly and instantly when I reuse an older version for your card (from about 3 weeks ago)


#838

Not sure whats going on there. The card values update correctly for me as do all other cards. What hardware are you running HA on ?


#839

I am running Hassio 0.87 on a Raspberry Pi 3B+.
I have rebooted and cleared browser cache, but no change. I will check again tomorrow.


#840

New version released here

0.9.4

  • Modified card refresh logic to allow an interval between card refreshes. This should help lower cpu powered devices to not be overwhelmed by multiple hass changes / sec.
  • Added refresh_interval flag to config. Can be used to specify the number of seconds between card value refreshes. Defaults to 30.
  • @VirtualL Modified card to allow RTL languages
  • @VirtualL Added Hebrew language

#841

Just updated the card with refresh intervals between card refreshes. Before this the card would try to refresh every time there was a change in the underlying hass object. This can happen multiple times a second depending on how many devices / sensors you have and how often they change. As the values for the weather card really don’t need to change that fast, there is now a default 30 second interval between card refresh attempts. The value is adjustable via the refresh_interval flag. This should help when using devices with lower powered CPU’s.

Try the latest version and let me know if it helps. On my system it reduced the cpu load for the card when it is visible by about 50% (6% down to 3%).


#843

not sure what might be different in your setup but mine is working fine with the new version
image


#844

NVM… something really screwey happened in my Lovelace and I have no idea why… fixed and all is well again. So weird.


#845

I’m amused that if you change your units to Fahrenheit, that’s my weather! :smile:

I’m about to update my card…

Edited to add: latest card is working fine for me.


#846

Thanks for your reply.
Unfortunately, the weather card does not update automatically :confused: (tested with the latest version of chrome on a desktop computer + smartphones). The refresh of my other elements (the state of lights for instance) work a little better with the new card, but it’s not perfect yet. I still need to refresh manually from time to time to display the proper state of lights.


#847

Not sure whats up with the card not updating. Can you test it with a fast changing entity. ie: replace entity_wind_speed (assuming you use it) with a numeric entity that changes every few seconds.

Keep in mind that at it’s default setting the card will only update once every 30 seconds (assuming that something has changed in the weather information). Also keep in mind that the update interval set on your dark_sky sensor config will control how often HA will check dark sky for new data. I have mine set to 5 min which is probably way to fast as weather really doesn’t change that fast.

As for your other cards missing updates, try changing refresh_interval flag to a value larger than 30, say 60 and see if that helps.


#848

I have tried with a fast changing entity (random sensor updating every 20 seconds), and replaced wind speed with the value from this random sensor. Unfortunately, it still did not refresh automatically, even after waiting more than 30 minutes. (Dark sky is set to update every 5 minutes)


#849

Very odd… Dynamic updating works fine for me and no one else has reported the issue. I have to assume there is something unique about your setup that is conflicting with the updating logic. Are you using card-modder or any other custom component that tries to alter the card’s appearance?

I think to isolate the issue we need to isolate the card. Can you create a new view in Lovelace and put the card on it. It should be the only card in the view. Test that configuration using a fast changing entity. If it still is not working in your system, you will need to use the Chrome Developer tools to debug the card. I can walk you through that if we get to that point.