Custom element doesn't exist for any plugin

Hi, I’m using HACS to do some customisations and can add themes and integrations without issue. However, when adding plugins either by HACS or manually I get Custom element doesn’t exist!

I posted on the HACS github as a question and it was kindly confirmed that HACS is working correctly.
(I did follow exactly the installation and configuration of each plugin)

I ran a debug and no errors show up. I used Chrome and the developers tools to see if there were any errors and there are none.
I’ve double checked file permissions and the formatting of my YAML files but still no progress?

My setup is HASSIO (HomeAssistant 0.100.2) via DockerCE on Ubuntu 18.04.3 all. HACS version is 0.15.7 and was installed as an integration.
If I mount my hassio using sshfs then I can see all the files are present and if using the ‘open plugin’ ling in the HACS interface I can view the plugin in the browser.
The two pluging I am trying to configure are Weather Card and Surveillance Card. I have also tried to install the dark-sky-weather-card manually. Unfortunately the result is the same.

The relevant parts of my lovelace UI are:

  - type: module
    url: /community_plugin/weather-card/weather-card.js
  - type: module
    url: /community_plugin/gauge-card/gauge-card.js
  - type: module
    url: /community_plugin/surveillance-card/surveillance-card.js
  - type: module
    url: /community_plugin/list-card/list-card.js
  - type: module
    url: /local/custom_ui/dark-sky-weather-card.js?v=7.1

For the card configuration:

      - entity: sensor.cluster1_temperature
        max: 100
        min: 0
        name: Study temp
          green: 13
          red: 30
          yellow: 20
        theme: default
        type: gauge
      - entities:
          - entity: sensor.potential_breaking_changes
            name: Breaking changes
          - entity: sensor.hacs
            name: Community updates
          - entity: binary_sensor.updater
        type: entities
      - entities:
          - entity: person.john
        show_header_toggle: false
        title: Whos home
        type: entities
      - entity: weather.dark_sky
        type: 'custom:weather-card'
    icon: 'mdi:test-tube'
    title: test
  - cards:
      - cameras:
          - entity: camera.1_front_door
          - entity: camera.2_garden
          - entity: camera.3_brewery
          - entity: camera.4_study
        thumb_interval: 15
        type: 'custom:surveillance-card'
        update_interval: 2
    icon: 'mdi:cctv'
    panel: true
    title: Surveillance

I’ve added these as I have shovel hands and fingers. So you never know!

Any help or ideas would be very much appreciated.

Well there you have it!
shovel fingers strikes again.
After slogging away pulling whats left of my hair out I had miss-spelled resources as recources.
I copied it from somewhere so now to find out where that was.

Hi i have problems with this “doesn’t exist” thing too. First time i try to get custom cards working on my

-I use yaml editor not UI.

Here my config in “ui-lovelace.yaml”.

  - title: Main
      - url: /local/gauge-card.js?v=1
        type: js
      - url: /local/custom-lovelace/bar-card/bar-card.js?v=1.2.0
        type: js
      - url: /local/button-card.js
        type: module
    panel: true
    icon: mdi:home-outline
      - type: picture-elements
        image: /local/pohja444.png

          -  type: "custom:gauge-card"
             title: test gauge
             name: test gauge
             entity: sensor.efergy_795151
             scale: 30px
             min: 0
             max: 8000
               red: 300
               green: 0
               amber: 150
               top: 99.4%
               left: 10.2%
          - type: "custom:bar-card"
            title: Default
            entity: sensor.efergy_795151
              top: 98.4%
              left: 50.2%

Try many different custom cards but nothing works always get message: Custom element doesn’t exist

Screenshot error messages my frontend:

File destination:
…be inside www folder.

bar-card is inside: \www\custom-lovelace\bar-card - folder.

( Lovelace: Bar Card )

Hopefully someone can help me with this problem. Not understand what is problem with this.

resources go at the top of the file outside your view

  ... etc...

- title: Main
  ... etc...
1 Like

Many thanks for that, that helps everything working now. Not good idea try to handle that problems too tired :smiley:

1 Like