Custom sensor hiding or grouping

So confused on how this is not working. I’m using HA 84.6 if it makes a difference.

I have the sensor below, as well as 6 others; all of the values look fine. However, I don’t want to see them, so I chose to use hidden: true under customization but they still how up on the states page.

I then decided to group them, that didn’t work either.


        friendly_name: "Game Temperature"
        unit_of_measurement: '°F'
        value_template: "{{ states('sensor.blink_game_room_temperature') }}"

        name: Room Temperatures
         - sensor.temp1
         - sensor.temp2
         - sensor.temp3
         - sensor.temp4
         - sensor.temp5
         - sensor.temp6
         - sensor.temp7

With the understanding this is over 8 month old, did you ever figure thi out?

It’s impossible to hide things in the dev states page.
The customize option hidden: true will only hide entities in the old interface, which is buried away now.
In Lovelace (the current UI), just remove the item from the page by editing the UI.

Thanks for the follow-up. After reading through several threads I pretty much came to the same conclusion.

The issue isn’t with Lovelace and what it is showing since I customized it, I was trying to find a method to remove unused sensors from the STATES tab as its getting very large with sensors I don’t use. I did learn that if I ignore them via zwave_device_config.yaml they no longer show up on the STATES tab, unfortunately, you have to do one by one…

You know you can search the states page right?

Yes, but even with that I feel like it still shows too many sensors, for example, when I search for living_room it brings up 23 sensors that have living_room in it. I know I can narrow down but I would have to remember how I named everything.