Custom sentence starting with Set

Hi all,
have any of you encountered a problem setting custom sentence starting with Set word? I am trying to create new automation, using UI, and my sentence is like:

Set {number} {unit} {name} test

I have tried multiple various combinations but always get the same result
"I am not aware of any device called ..."

Am I doing something wrong or is it not possible to use a custom sentence starting with Set word?

There is no direct ban on use, but you get to the existing intent.
Use Developer tools - Assist to find out the details

Try replacing the Units variable with a fixed value. Then it will be easier for the engine to determine the required query.

1 Like

Yeah for some reason it calls HassLightSet intent, no matter what. Do you know if there is any option to change priority to first match automation sentences? Or will it help if I move it to yaml file maybe?

Replacing unit with fixed value did help, but it get’s more tricky to check it.

Thx, that was a good shout :slight_smile:

The assist architecture prefers built-in intents. This cannot be changed at the moment.

You need to create a unique pattern. use particles or an article between units and a name, for example.

If you do not control the light, you can remove this domain or specify the necessary one.



domain: light

If you need to understand which sentences аre already being used, you can look at the code on github.

1 Like