Custom Updater keeps showing update available after ha restart

Since the last update of custom updater, it shows me update available after each ha restart.
And of course there is no update available.

Does someone else have that issue too?

custom updater version 4.2.15
ha 0.88.1

ha 0.88.2 was released yesterday.

Perhaps there really IS an update this time :wink:

But custom updater doesn’t look for the ha version. It only looks for custom components and lovelace cards.

Not 100% sure about this, but I believe it looks for versions in two places – in the local copy of the custom component, and in a centrally maintained json file. The json file (I think) is only updated every hour or so. So, if you haven’t updated in a while, it’s possible there may have been more than one update to a component. And if you just happen to update during that period before the json file is updated, it’s possible to get a newer version of the component than the json file thinks exists. Then when you check, it will say there’s an update, but if you look closely, the “remote” version will actually be less than the local version. If you wait long enough, and then run the custom_updater.check_all service, or just wait until it runs automatically, the situation will clear itself up. I’m pretty sure I’ve seen this happen.

In case I didn’t explain that very well, here’s a concrete example. Say you have version 1.0.0 of some component. Then at some point 1.1.0 comes out, but you don’t update yet. Before long the json file will be updated to say 1.1.0 is the latest. Then 1.2.0 comes out, and while the json file still says 1.1.0 you check for updates. It will say you have 1.0.0 and 1.1.0 is available. So you update. But now you have 1.2.0. So when you check it will say the latest is (still) 1.1.0 and the local version is 1.2.0. Since they don’t agree it says an update is available. Now, if you wait long enough, it will eventually say the latest is 1.2.0, which agrees with what you have, so it no longer says an update is available.

Thanks. The thing is that it only shows “update available” after a restart.

If I delete the persistant notification and check manually again, it does not show “update available” again.

Restart and it shows up again.

Oh, well that’s odd. @ludeeus, any ideas here?

I already deleted the old custom_updater.py file and replaced it with the newest one.
Still the same issue.

All my cards and components show as newest version.

A persistent notification is not a part of that component (yet), so if that happens you have an automation that is not working correctly.

Thanks for pointing me in that direction, I forgot that I setup the persitant notification myself.

This is the binary sensor that worked before, now it seems like has_update isn’t empty any more, so this sensors stays true. It reports “false”.

- platform: template
  sensors:
    custom_component_has_no_update:
      value_template: "{{ states.sensor.custom_component_tracker.attributes.has_update == [] }}"

had it from here:
https://github.com/custom-components/custom_updater/issues/68

I indeed had a faulty automation

You can see the binary sensor above.

And this was my automation trigger

  trigger:
    platform: state
    entity_id: binary_sensor.custom_component_has_no_update
    to: 'on' 

And of course this has trigger when it goes to ‘off’, because its true when there is no update.
I don’t know why (i had the feelling) that it worked before. It did show a persistant not when there was a new update.
Don’t know why…

1 Like

I’m also attempting to delete a custom updater install from hass.io 88.2. I’ve deleted custom.updater.py from custom_components, the pycache file, removed custom_updater: from configuration.yaml, and removed the resource from the .storage/lovelace file. I’m still getting this error on restart:

INFO:homeassistant.util.package:Attempting install of colorlog==4.0.2
Testing configuration at /config
Failed config
  General Errors: 
    - Component not found: custom_updater
Successful config (partial)

What have i missed?

I found the problem.

So you deleted that files withour replacing them with the new versions?

If yes you probably have to comment out those lines in the configuration.yaml too. Else it will search for that component.

Edit: Missen the “I found the problem”. Maybe you want to share your issue.