D-link DCS 5000L issue

Hi! Bought a D-Link DCS 5000L and manages to connect to the HA. I use the following config

- platform: mjpeg
  username: !USERNAME!!
  password: !PASSWORD!
  authentication: digest

In my loggfile i got a [auth:false]

After a while the camera stop in HA and on d-links config site. At the moment i’m running without sync to HA and the camera runs smooth and don’t stop.

Anyone that have the same problem or use a d-link camera that can post config.

Pase a section from my loggfile.

16-10-30 14:07:45 homeassistant.components.http: Serving / to (auth: False)
16-10-30 14:07:46 homeassistant.components.http: Serving /api/bootstrap to (auth: True)
16-10-30 14:07:46 homeassistant.components.http: Serving /api/stream to (auth: True)
16-10-30 14:07:48 homeassistant.components.http: Serving /api/camera_proxy/camera.mjpeg_camera to (auth: False)
16-10-30 14:07:48 requests.packages.urllib3.connectionpool: Failed to parse headers (url= [StartBoundaryNotFoundDefect(), MultipartInvariantViolationDefect()], unparsed data: ''
Traceback (most recent call last):
  File "/usr/local/lib/python3.4/dist-packages/requests/packages/urllib3/connectionpool.py", line 404, in _make_request
  File "/usr/local/lib/python3.4/dist-packages/requests/packages/urllib3/util/response.py", line 59, in assert_header_parsing
    raise HeaderParsingError(defects=defects, unparsed_data=unparsed_data)
requests.packages.urllib3.exceptions.HeaderParsingError: [StartBoundaryNotFoundDefect(), MultipartInvariantViolationDefect()], unparsed data: ''

Why is the camera use when the camera is on

The camera has both an ethernet port and wifi. Is it possible that both are active, hence the 2 IP addresses. Try disabling one of the connections and try again.

Tried but same problem. Thanks for the tip.

What do the logs indicate now? Before you had it trying to authenticate to .139

Hi! Just got one of these cameras…have you solved it? i only get “error loading image” on mine…

Please post your config. It sounds like wrong IP or port. My cameras works good now.


I can paset both URL in to Chrome and see both video and still images. Can this be that the camera does not have a ddns set and that the server does? I only access the server thru a duckdns adress and with SSL.

Hi! This is my config and it’s works good for me. I only use video at the moment.

  - platform: mjpeg
    name: !SECRET!
    username: !SECRET!
    password: !SECRET!

Image should be

Yes! You solved it! Many thanks!!


I bought this camera DCS -5000L I would like to have the picture with this string: Unfortunately, I still receive an additional login command. Why?

I have the same issue when trying to logon to the camera webserver. Somewhere on the internet I read the default login is admin without password but it continues asking me login and password. On the small card with the QR code of the camera I found the SSID of the camera network with a password but that network I do not see in my surrounding. I want to download recorded videos.
Thanks in advance,


And make sure that it is allow in UI. You find it under maintenance. Enable snapshot URL.

I think you have to set up a event to download files from the ip camera.