Dafoss LC-13 wake-up time


I do have a zwave configuration with danfoss LC-13 thermostats in it.

I want to set the wake-up interval to a couple of hours during summer, but it seems that the maximum on the thermostats I have is set to 30 minutes (or 1800 seconds).
I can set that by using this action:

  - service: zwave_js.set_value
      command_class: "132"
      property: wakeUpInterval
      value: 1800
      device_id: xxxxxxxxxxx

When I put a higher number in value, it jumps back to 1800.

In the manuals it says that the best wake-up interval should be 1 hour when not frequently used.
So there should be a way to set the maximum higher than 30 minutes, but I don’t know how.
Can anyone help with this?

Is this a printed manual you have in hand, or an online manual? The only manuals I could find online don’t mention this. There is one statement about not going below 5 minutes.

If values above 1800 seconds are not being accepted, then most likely 1800 is the maximum value. AFAIK, the driver itself does not perform any min/max checks. You can confirm by reviewing the driver debug logs when setting the values. If the correct value is set, but the device reports something else, it means it wasn’t accepted.

Of course, the device does need to wake up to accept any new values. The reported value will still be the old one until that occurs.

Online on a github forum:

The LC-13 does not permanently listen for messages sent from the controller - it will periodically wake up automatically to check if the controller has messages to send, but will sleep most of the time to conserve battery life. The wakeup period can be configured in the user interface - it is advisable not to make this too short as it will impact battery life - a reasonable compromise is 1 hour.

But no clue how to set that.
When set higher than 1800, a moment that higher value is show, than 1800.
So the only way to get it higher than 1800 would be to put a higher maximum somewhere in the thermostat itself. I think that will be inpossible.

So: thanks for your reaction.

Did you check the driver logs?