Daikin Aircon Automation

Tags: #<Tag:0x00007f3f1b6bb960>

First post so please forgive me if I failed at some formatting protocol. I am trying to create an automation to turn on the Daikin airconditioner at 6:45am, set the temp to 20, set the mode to heat and the fan to Mid. Any of the functions will turn it on if off.
When the below automation runs, only the first action happens. If I make 3 automations, 1 for each action, they all work fine. Can someone help me please. The below was writen using the Automation Editor.

# Turn on and set Aircon
-  alias: ' Aircon on at 6:45am. Set to 20c.'
  trigger:
  - at: 06:45
    platform: time
  condition:
  - condition: state
    entity_id: binary_sensor.workday_sensor
    state: 'on'action:
 - data:
      entity_id: climate.daikinap33707
      temperature: 20
    service: climate.set_temperature
  - data:
      entity_id: climate.daikinap33707
      operation_mode: heat
    service: climate.set_operation_mode
  - data:
      entity_id: climate.daikinap33707
      fan_mode: Mid
    service: climate.set_fan_mode

See point 11 here to correct your post: How to help us help you - or How to ask a good question

Thanks Tom, I put the ``` at beginning and end. I tried to do more but nothing seemed to work.

That formatting is excellent. Well done. This bit does not look correct:

    entity_id: binary_sensor.workday_sensor
    state: 'on'action:
 - data:

The action: block should be on its own line.

Also the alias: line has one too many spaces after the -.

Writing your automation in human readable format (rather than automation editor mangled format) it would look like this:

# Turn on and set Aircon
- alias: ' Aircon on at 6:45am. Set to 20c.'
  trigger:
    - platform: time
      at: '06:45:00'
  condition:
    - condition: state
      entity_id: binary_sensor.workday_sensor
      state: 'on'
  action:
    - service: climate.set_temperature
      data:
        entity_id: climate.daikinap33707
        temperature: 20
        operation_mode: heat 
    - service: climate.set_fan_mode
      data:
        entity_id: climate.daikinap33707
        fan_mode: 'Mid'

You can set the operation mode when setting the temperature. No need for an extra service call. This was all taken from the examples here:

The example for setting the operation_mode lists Heat with a capital H but you say it is working when used in a standalone automation so this is probably not an issue.

Run the automation and if it does not work as expected check the log for errors.