Daikin app controller firmware update from 1.19.0 to 2.8.0, now it is broken!

Yesterday, there was an update to the IOS Daikin controller, when this was updated, it showed that a firmware update was available for the controller which was running at 1.19.0, and all good.
The update was ver 2.8.0 so that was done. The mobile app is fine and controls as expected, all good.

However, HA latest on version 2023.8.3, failed to connect, so all entities unavailable.
Tried to communicate directly with the API commands on the host address, “page not found”, was the result. So I can no longer communicate with it directly as before.

I don’t think that I can roll back the update on the controller.
BTW, I’ve just found out today that the controller is “BRP084C44” for information.
See below link.
Daikin (daikinthai.com)

Any thoughts?


Whenever something like this happens a good place to check is the known issues link on the integration page:

There don’t appear to be any issues open or closed that relate to that adaptor or firmware. That could mean you are the first to update the firmware or it is something else.

Have a look at the Daikin Device in your Devices and Services page. Is there a duplicate Device there?

Some changes were made to the integration naming and this has generated a duplicate device for a lot of people. The duplicate works but the originally named device does not.

If this is the case then this is the issue: Daikin fails after update to 2023.7.2 · Issue #96530 · home-assistant/core · GitHub

Thanks for your response.
Yes, it does seem that I may be the first to do the firmware update.
The fact that the API is also broken now, explains to be why HA can no longer communicate.
It seems I can not rollback the firmware.

Same thing happened to me. Daikin forced me to update the firmware on my FTXM71WVMA, it wouldn’t connect using the Daikin app or HA until I updated.

Since the update I can’t connect the unit to HA, or google home. Daikin app works as normal both in home and away.

Firmware 2.8.0
Any help?

1 Like

It is good to know that I’m not alone with this issue, I have send a message to Daikin about this, I’m not expecting a response, but if I do, I don’t think it will be useful, a roll back would be useful for the firmware or a further update fix would be helpful.

You will also have the issue that the API no longer works either.
for example try the following on the host address.
you get huge list of t&c’s, licence, etcc all useless.
So now that the API no longer works, HA can’t communicate either.

You may want to send a message to Daikin directly too, so they know it is not an isolated issue.

Please report this as a new issue here:

This way the developers will be aware of the issue and may be able to fix it. They are very active.

I just saw this and commented on the reported issue there in github. I am not sure if my issue is related but looks like i have the same built-in wifi controller. My AC is FTXM20WVMA in Australia.

However, I can’t even get to this endpoint http://[ip]/aircon/get_model_info on mine, both from the one running 1.1.30 and another 2.8.0. It just returns 404 page not found.

I have heard that Daikin are going Cloud only, so removing the unofficial local API. That sounds like that is what happened here.
If that is the case, then you need to switch to the Daikin HACS integration.

Yes, it works through the cloud, but it does work, and therefore if anyone has upgraded, you should be able use that.

Hi Scriven33
I did have a look at your suggested method, however, the first difference is the login, an email is required.
Previously, with the Daikin Mobile Controller App, only a userid and password was required. And that login works for that app just fine. Anyway tried with my userid instead of email, but failed.
Is a different app required, to use this HACS integration?

Please see this comment from the Daikin integration developer:

I also failed to use that integration. It probably is meant for other region’s Daikin app. AU uses Daikin Mobile Controller App and i also can’t login. So far I couldn’t find anything that works.

Hi Mark,
Yep, agree.
I did find an ESPHome solution that works with the Daikin IR remote commands, see link ( simple circuit)

I still preferred the local control that we had, but this maybe a solution that will not disappear over time.

1 Like

Same issue. Daikin API doesn’t return any value after upgrade Firmware to 2.8.0

1 Like

For now I just use SmartIR with a Broadlink RM4pro and a RM4 mini that have been there controlling my TV and my dumb ceiing fan. It is not ideal since it’s just one-way control without knowing the status. But that’s the best i can do for now to control the aircon.

I have installed these ZigBee switches inbetween the power outlet and the power input of our indoor units. They are small enough to fit inside the housing. Since they are monitoring electricity usage with a little tuning you can get the status of your AC in real time through HA (on Z2M here). They work very reliable here.

Thanks for sharing.

That’s interesting. So do you use IR to control your aircon but with the help of this energy monitor you get the accurate status of whether it’s on or off?

The monitor looks awesome but I believe by law in Australia one can’t install it unless it’s the electrician doing it?

Correct. Broadlink 12 x RM4/RM4c minis (for 12 AC units). I’ve put them inside the indoor units close to the IR receivers. Thus no IR blasters laying around.

Yup. Instantly. And if you take your time to measure wattage used by the AC units you can also differentiate between the AC modes (is cooling/heating or in fan mode).

How it looks in Lovelace you can see here.

I can not answer you this one since I am not living in Austrailia. However, with some basic knowledge about electrical systems (basically only Lin, Lout, Nin and Nout) installation is a breeze.

1 Like

So you connected it between the phase from the outdoor unit to the indoor unit?
Do you know what happens if the ZigBee switch switches off the inddor unit, but the outdoor unit keeps running?

No, simply:

  • From circuit breaker: L (phase) → Lin → Lout → L at Indoor unit
  • From circuit breaker: N (neutral wire) → Nin → Nout → N at Indoor unit

If you have dedicated circuit breakers for your AC units you can even install these Zigbee relays into the circuit breaker box. A DIN rail clamp comes with every switch.

This will also cut-off power to the outdoor unit if you switch the relay to off. Thus the outdoor unit wont keep running.

The indoor unit usually has no dedicated circuit breaker as it is usually directly connect to the outdoor unit.

The wiring is showm in the last picture of this first post. One wire is the control signal between indoor and outdoor unit.