Daikin app controller firmware update from 1.19.0 to 2.8.0, now it is broken!

FWIW, I would abandon the OEM Daikin Wifi controllers, and use an ESP32 with “Faikin”.

We have the same problem. Interestingly, this app that creates a Homekit bridge works perfectly with our Alira X (adapter BRP084C44) without cloud or login.

Running this auto detects one of our aircons and creates a Homekit device that works instantly. My coding skills are pretty bad but it might be helpful for a HA integration for someone!

2 Likes

Hi all

Here is a temporary solution to this issue. Read the readme for more details. Hope it helps someone!

Hi Apoc182,
Great start, I’ve tried your integration and yep it does work with what you have done, so highly recommend other to also give a try.
For you information my AC is a Alira X (adapter BRP084C44) here in Australia.
As you make improvements to this, is it possible to add the option to use another external Temperature sensor instead of the Daikin internal temp sensor?

OK clearly I’m missing something - I can’t find the integration in HACS! Tried searching local_daikin and just daikin… What am I missing here?

You will need to add it as a custom repository.

1 Like