Daikin BRP072C42 WIFI custom component

Hi, yes found new devices. But then get the same prompt to enter details if I were to follow the same process of adding the integration.

I was able to successfully add one unit to HA. I entered the IP and the SSID key as the API key. What I noticed with the discovery is that it only found two (I have three total), however, in the Daikin app, when it is “at home” it only shows the two units discovered. I will need to fix the third unit. Funny though, all three units show out of home.

1 Like

Hi All I have the Australian model that requires the API Key and pass. I have looked at the back of the WIFI unit. Its has SSID, Key, Mac and S/N. Can someone please tell me which is the API key and which is the pass?

Thanks in advance

hi @bdb1, I just used the IP of the AC and the API key = SSID key on the AC label you refer to. I did not enter a password. Please note, you must have all ACs in the app and working in “out-of-home” first as I understand it.

Thanks so much for the fast reply. I tried not putting no password. My SSID is DaikinAP77xxx (note the x’s are numbers. I then have a key which is a bunch of number. I enabled out of home mode and no go! Tried a reload too.

Thoughts

So got it Fixed. Once auto discovered put in IP and then ONLY the 10 digit number into the API key box, no pass.

Glad to hear you were able to get it to work

Me too, thanks :slight_smile:

Is anyone having the issue whereby they are losing connectivity to an AC consistently (seems mostly after a HA reboot)? I have three units, but the same unit I keep losing connection to. The other two I have no issues with.

  • Core2024.2.0
  • Supervisor2024.01.1
  • Operating System11.5
  • Frontend20240207.0

hello all !
reading this track, is there some experience with HA integration coming back immediately with “Failed to connect” .
The Daikin controller is a BRP069C41, which is visible on the local LAN with fixed IP (dhcp static) address, it does react to port 80 and replies to SOME http ‘GET’ requests:
/common/get_remote_method:
ret=OK,method=home only,notice_ip_int=0,notice_sync_int=0
/common/basic_info:
ret=OK,type=aircon,subtype=qa,reg=eu,dst=1,ver=1_24_0,rev=4A7D65DF,pow=0,err=0,location=0,name=%44%61%69%6b%69%6e%41%50%35%34%37%34%37,icon=0,method=home only,port=0,id=,lpw_flag=0,adp_kind=4,pv=0,cpv=0,led=1,en_setzone=1,mac=E84F25CDF1F8,ssid=DaikinAP54747,adp_mode=ap_run,en_hol=0,grp_name=,en_grp=0,edid=0000000002724700,sw_id=1900292F,pw=,ssid1=xxx,radio1=-61
it is responding with Page Not Found /aircon/get_control_info to ANY /aircon/ GET request …

i also have a ‘key’ printed on the label, which allows to connect any wifi device to
the “DaikinAP54747” and do some initial setup like join the local Wifi (which works).
The local (Android) app called Onecta is also failing to complete the addition of the device to local network … but as stated before, the device HAS joined local wifi and IS responding to http requests … being stuck here - any idea howto proceed ?

thanks in advance !