Daikin Component - no climate entities created - task exception

Hi There,

Just upgraded to 0.61 on hass.io with a Raspberry PI3.

I’m using BRP072A42 adapters but can’t get things to work.

If i use the configuration based on the main component https://home-assistant.io/components/daikin/ i get sensor entities created for inside and outside temperature for each host defined but don’t get any climate entities.

If i add configuration based on the client component “climate.daikin” I get errors during startup related to “KeyError: ‘f_rate’” and get no climate entities created, errors below.

Any ideas…

2018-01-17 13:42:42 ERROR (MainThread) [homeassistant.core] Error doing job: Task exception was never retrieved
Traceback (most recent call last):
File “/usr/lib/python3.6/asyncio/tasks.py”, line 180, in _step
result = coro.send(None)
File “/usr/lib/python3.6/site-packages/homeassistant/helpers/entity_component.py”, line 399, in async_process_entity
new_entity, self, update_before_add=update_before_add
File “/usr/lib/python3.6/site-packages/homeassistant/helpers/entity_component.py”, line 247, in async_add_entity
yield from entity.async_update_ha_state()
File “/usr/lib/python3.6/site-packages/homeassistant/helpers/entity.py”, line 217, in async_update_ha_state
attr = self.state_attributes or {}
File “/usr/lib/python3.6/site-packages/homeassistant/components/climate/init.py”, line 521, in state_attributes
fan_mode = self.current_fan_mode
File “/usr/lib/python3.6/site-packages/homeassistant/components/climate/daikin.py”, line 229, in current_fan_mode
return self.get(ATTR_FAN_MODE)
File “/usr/lib/python3.6/site-packages/homeassistant/components/climate/daikin.py”, line 120, in get
value = self._api.device.represent(‘f_rate’)[1].title()
File “/usr/lib/python3.6/site-packages/pydaikin/appliance.py”, line 145, in represent
v = self.values[key]
KeyError: ‘f_rate’

1 Like

Same error, same result . Same br adaptor for me as well

Hass.io 61.1
I don’t have any error in logs. But the daikin climate ui does not show up anymore
I do see two new sensors

  • sensor.inside_temperature_house_inside_temperature
  • sensor.outside_temperature_house_outside_temperature

I’ve been using the @rofrantz component up to now and it was working perfectly
Note: I have discovery turned off, if that can be of any help

Just to be sure. Before, with the @rofrantz custom component, I had it configured like

  - platform: daikin
    host: x.x.x.x

while now, I should use

    - x.x.x.x

is that right?

Not yet because netdisco (autodiscovery) component was not upgraded yet I think.
I havent tried it yet but let me know if it works or not

i’m not sure what you mean.
if you mean discovery, i have disabled it. I can enable it and check.
if you mean the whole component, no it’s not working. I see the two new sensor but not the climate component

I’ll try to check the main component this weekend since as u were saying it was working. They’ve probably changed smth with the latest release.

I’ll try to add also discovery since they’ve merged my fix for network discovery so u don’t need to specify the host anymore @ekt.

tl;dr: plugin is ok. was just naming.

I think I found the problem. Basically I’m still ignorant in ha, I should have checked.
In your initial implementation, the default entity name was ‘daikin’. To show it, in my group I had:

  view: no
   - climate.daikin
   - sensor.daikin_outdoor

now the entity is being automatically named ‘climate.hallway’ where ‘hallway’ is the name I gave to that split in the daikin android app. I should have checked the ‘States’ page first

All this happens because I didn’t set a ‘name’ entry in the climate definition.

Last thing: I think the current implementation is better, because it avoids issues in cases when one has more then one device.

Thanks a lot for you work, by the way


Did you ever get this to work with the BRP072A42?

I am considering ordering one of these adapters for the unit in my office if it works.



Nope still have the problem. looks like i have a different problem to @ekt as i’m getting a task exception on startup related to the climate component. Sensor is working as needed, I suspect some sort of packaging issue where not all of @rofrantz changes got incorporated…

@brettjonesoz it seems u don’t have the f_rate (fan speed) info from daikin. Can u tell me what http://[YOUR_DAIKIN_IP]/aircon/get_control_info output is ?

@ekt I didn’t really understood from ur last response if everything’s ok for you or not after that naming issue u discovered in ur config. Can u please let me know ?
Thanks everyone for ur feedback

@rofrantz yes is ok. everything works great.


Indeed @peterho its way I was expecting u guys don’t have f_rate ( fan speed control) that we all have on our BRP models and i’ve tested on two models so far.
This is what I have:


Can u however help me understand ur device by answering a couple of questions:

  1. is it an air conditioning device, if yes what model ?
  2. can u control the fan speed from ur remote control ?
  3. can u control the fan speed from ur android or ios device or simply doesn’t support it ?

‘/common/basic_info’ answer contains a ‘ver’ entry. just to be sure the firmware version
I’d also try: /aircon/get_model_info

Get_model_info returns the following

Basic_info returns the following (I redacted /removed a couple of values for anonymity in inverted commas)

Its great @peterho but can u please answer to the 3 questions I’ve asked before providing info that I didnt asked yet ?

  1. is it an air conditioning device, if yes what model ?
  2. can u control the fan speed from ur remote control ?
  3. can u control the fan speed from ur android or ios device or simply doesn’t support it ?
  1. Model airco head unit fdxs60cvma.
    Wi-Fi card model brp072a42 connected to s21 port on head unit airco board
  2. Fan speed. On the airco remote you have option of normal, powerful (high) or home leave (low). There is also on the slide out covered portion a fan speed button. Cycling through fan speed has the following. A (auto), eco, then 1 through 5. There is also a separate button for quiet. (I’ll attach photo in next post of remote)
  3. On android app version d-mobile those fan options are not available. Basically
    on / off.
    Temperature set
    Temperature current inside and outside.
    Then modes of auto cool heat fan or dry (screenshot attached)

Remote control photo attached